Ask Your Question
1

.../install/lib/uwsim/uwsim_binary: error while loading shared libraries: libosgbCollision.so.2.00.02: cannot open shared object file: No such file or directory

asked 2014-06-30 13:24:19 -0500

a3738294 gravatar image

updated 2014-06-30 13:27:23 -0500

This is a solved question. I want to make it public.

After updating a lot of hydro packages, when I run:

$ rosrun uwsim uwsim --disableShaders

I obtained this:

Starting UWSim...
/home/foo/catkin_ws/install/lib/uwsim/uwsim_binary: error while loading shared libraries: libosgbCollision.so.2.00.02: cannot open shared object file: No such file or directory

As someone wiser than me told me, a few months ago UWSim dependencies were updated for using bullet 2.82 (from there the osgbullet error) and unfortunately the change is not compatible with what had preceded.

I needed to upgrade my simulator version for using this bullet version.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2014-06-30 13:26:54 -0500

a3738294 gravatar image

Solution: Simply making a git pull inside catkin_ws/src/underwater_simulation directory should be sufficient (Of course, followed by a catkin_make install inside catkin_ws directory to compile).

As I didn't modify anything inside that directory I had no problem. If I had done so, it would be possible to have conflict trying to join the new files with the modified ones.

edit flag offensive delete link more
0

answered 2014-09-12 23:04:21 -0500

Cong Wang gravatar image

Hi,

I have some problems on using command "rosrun uwsim uwsim" to run uwsim following errors are showing:

Jack@Jack:~$ rosrun uwsim uwsim Starting UWSim...
. Setting localized world: 6.1e-05s
Loading URDF robot...
· robot/GIRONA500/g500_March11.osg: 2.67438s · robot/ARM5E/ARM5E_part0.osg: 0.082435s · robot/ARM5E/ARM5E_part1.osg: 0.119529s · robot/ARM5E/ARM5E_part2.osg: 0.127205s · robot/ARM5E/ARM5E_part3.osg: 0.439133s · robot/ARM5E/ARM5E_part4_base.osg: 0.420119s · robot/ARM5E/ARM5E_part4_jaw1.osg: 0.065359s · robot/ARM5E/ARM5E_part4_jaw2.osg: 0.058875s
· Linking links.../opt/ros/groovy/lib/uwsim/uwsim: line 20: 25729 Segmentation fault (core dumped) rosrun uwsim uwsim_binary --dataPath ~/.uwsim/data $@

Thank you for your help!

edit flag offensive delete link more

Comments

  • Hi, I have a similar problem with my own package. I share install directory (catkin_make install generated it) and roslaunch found this error: "libyaml-cpp.so.0.2: cannot open shared object file: No such file or directory". My package use yaml.h for read param

Thanks in advance

Edmodi gravatar image Edmodi  ( 2015-02-06 09:50:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-06-30 13:24:19 -0500

Seen: 432 times

Last updated: Sep 12 '14