Ask Your Question

How to I fix undefined symbol error?

asked 2014-06-26 10:15:33 -0500

liangfok gravatar image

updated 2014-06-26 21:43:57 -0500

I recently upgraded to the most recent packages of ROS hydro and now when I launch gazebo using "rosrun gazebo_ros gazebo" I'm getting the following error:

gzserver: symbol lookup error: /opt/ros/hydro/lib/ undefined symbol: _ZN3ros7package10getPluginsERKSsS2_RSt6vectorISsSaISsEE

gzclient: symbol lookup error: /opt/ros/hydro/lib/ undefined symbol: _ZN3ros7package10getPluginsERKSsS2_RSt6vectorISsSaISsEE

Using c++filt or , I see that the following method is undefined:

ros::package::getPlugins(std::string const&, std::string const&, std::vector<std::string, std::allocator<std::string=""> >&)

Does anyone know how to fix this?

Here are the ROS / Gazebo packages I have installed on my Ubuntu 12.04.4 64-bit computer:

$ dpkg -l | grep hydro | grep gazebo
ii  ros-hydro-gazebo3-msgs                      2.4.2-3precise                                                          Message and service data structures for interacting with Gazebo from ROS.
ii  ros-hydro-gazebo3-plugins                   2.4.2-3precise                                                          Robot-independent Gazebo plugins for sensors, motors and dynamic reconfigurable components.
ii  ros-hydro-gazebo3-ros                       2.4.2-3precise                                                          Provides ROS plugins that offer message and service publishers for interfacing with Gazebo through ROS. Formally simulator_gazebo/gazebo

$ dpkg -l | grep gazebo
ii  gazebo3                                     3.0.0-3~precise                                                         Open Source Robotics Simulator
ii  gazebo3-common                              3.0.0-3~precise                                                         Open Source Robotics Simulator - Shared files
ii  gazebo3-plugin-base                         3.0.0-3~precise                                                         Open Source Robotics Simulator - base plug-ins
ii  libgazebo-dev                               3.0.0-3~precise                                                         Open Source Robotics Simulator - Development Files
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2014-07-08 11:13:31 -0500

bilynbk gravatar image

Dear liangfok, I used the same configuration as your system (Ubuntu 12.04+gazebo3+ros-hydro-gazebo3) and sadly got the same error. Still don't know how to get through. Does anyone help me out of this situation?

edit flag offensive delete link more



It works for me. Thanks for your help.

bilynbk gravatar image bilynbk  ( 2014-07-09 01:34:03 -0500 )edit

answered 2014-07-07 02:53:07 -0500

Girts L gravatar image

I had a similar problem with gazebo 2.0, this answer helped. After commenting out the OSRF repo, removing gazebo-current and reinstalling ros-hydro-turtlebot-simulator, which I was trying to run, I got gazebo 1.9.5 instead of 2.0. Now it works.

edit flag offensive delete link more


Unfortunately, I need to use Gazebo 3.0 because there is a critical flaw in previous versions of Gazebo that prevent me from accurately simulating my robot.

liangfok gravatar image liangfok  ( 2014-07-08 11:46:59 -0500 )edit

Could you please check the gazebo bug and see if the proposed solution fix the problem for you? For some reason the captcha is stopping me from post an answer.

Jose Luis Rivero gravatar image Jose Luis Rivero  ( 2014-08-05 18:33:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-06-26 10:15:33 -0500

Seen: 1,199 times

Last updated: Jul 08 '14