Ask Your Question
0

Moveit cannot load planning library when roscore is running on remote (non-localhost) pc

asked 2014-06-23 16:24:11 -0600

rkitect gravatar image

updated 2014-06-23 23:52:05 -0600

fergs gravatar image

I am trying to get moveit working for Barrett-WAM. WAM has an internal pc which is running wam_node. I have a driver that publishes on wam_node topics from an external PC on the same network via LAN. Driver works perfectly. I can control the arm from an external PC via LAN. I think that means all the settings are correct. settings on external PC: ROS_IP=127.0.0.1 ROS_HOSTNAME=127.0.0.1 ROS_MASTER_URI=192.168.111.101 and in /etc/hosts I have an entry " 192.168.111.101 WAM"

I have never required to change any settings on WAM (internal PC) to send messages to wam_node via LAN.

But when I run the following command on external PC roslaunch wam_moveit_config demo.launch

This is the Output: (Partial)

[ERROR] [1403555647.510816509]: The kinematics plugin (arm) failed to load. Error: According to the loaded plugin descriptions the class wam_arm_kinematics/IKFastKinematicsPlugin with base class type kinematics::KinematicsBase does not exist. Declared types are  kdl_kinematics_plugin/KDLKinematicsPlugin pr2_arm_kinematics/PR2ArmKinematicsPlugin

and

[ERROR] [1403555690.896934602]: Unable to connect to action server within allotted time

and Moveit.rviz says:

NO PLANNING LIBRARY LOADED

Does moveit work on network ? Am I missing something ?

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-06-23 23:57:41 -0600

fergs gravatar image

For the first error, loading a plugin has no interaction with the network -- but it does require that the plugin be built and the package it is in be on your path. How did you install wam_arm_kinematics, is it built? Is it on your path (can you "roscd wam_arm_kinematics")?

For the second error, this is almost certainly a network issue if your external computer declares ROS_IP=127.0.0.1 (the localhost) -- while the external PC can send messages to the internal one, there is no way that the internal machine can return messages to your external computer (since 127.0.0.1 will be interpreted as its own IP, not the external computer). Since message from the internal PC cannot get to the external PC, it will never be "connected" to the action. You should set the ROS_IP to something that the wam computer can actually find (be sure that the WAM computer can ping the external computer).

edit flag offensive delete link more

Comments

I changed the ROS_IP and ROS_HOSTNAME to the actual ip name. And it works fine. I can detect the OMPL now and it give the trajectories. I still get the first error though which I used to get before too. Thanks !!!

rkitect gravatar imagerkitect ( 2014-06-24 16:27:05 -0600 )edit

hello,can you tell me how to change the ROS_IP and ROS_HOSTNAME? Thanks.

jxbjnba gravatar imagejxbjnba ( 2016-05-14 05:35:47 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-06-23 16:24:11 -0600

Seen: 805 times

Last updated: Jun 23 '14