rgbd_eval not working. rgbdslam node missing in binary folder. [closed]

asked 2014-06-20 04:18:26 -0500

Joy gravatar image

I am using Fuerte to do RGBD Slam and my version is Ubuntu 12.04

I am currently working my progress on RGB-D SLAM Dataset and Benchmark . It involves evaluating RGBD-SLAM using Kinect datasets provided. This is because I saw in many research papers, kinect datas obtained are compared with the rgbd datasets online to determine the accuracy and trajectory error (pose and orientation of kinect).

My final aim: Measuring the quality of the estimated camera trajectory of visual SLAM systems.

What I did: I followed the tutorial is in this link: vision.in.tum.de/data/datasets/rgbd-dataset/rgbdslam_eval (with http:// in front of it)

I am currently trying to evaluate the bag.file provided in the tutorial with the datasets provided.

The bagfile is downloaded and the datasets are downloaded as well. The ros package downloaded is rgbdslam_eval inside cvpr-ros-pkg.

Problem 1: I do rosdep install rgbdslam_eval, but there is an error. ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: rgbdslam_eval: Cannot locate rosdep definition for [qt4]

From this link: stackoverflow.com/questions/11094619/in-ubuntu-12-04-make-cannot-find-qt-libraries (with http:// in front of it) I used "sudo apt-get install libqt4-*" Result: 0 upgraded, 0 newly installed, 0 to remove and 217 not upgraded. However "rosdep install rgbdslam_eval" still shows the same error

Problem 2: I tried to rosmake rgbdslam_eval Result: built 37 packages, 1 failure Error : eigen resource is missing

Followed the suggestion in this link answers.ros.org/question/38989/rgbdslam-with-ros-fuerte-installed/ (with http:// in front of it) By removing the <depend package="eigen"/> line and adding <rosdep name="eigen"/> Result: Rosmake for rgbdslam_eval succeeded with 37 packages built with 0 failures

Main Problem: Until the first step in Run RGBDSLAM section in the tutorial. When I used this command from the tutorial "rosrun rgbdslam_eval rgbdslam ~/data/rgbd_dataset_freiburg1_xyz-points.bag ~/data/rgbdslam_xyz.txt"

Error: [rosrun] Couldn't find executable named rgbdslam below /home/utp/fuerte_workspace/sandbox/cvpr-ros-pkg/rgbd_benchmark/rgbdslam_eval

Doubts / Questions: 1. Can rosmake be successful even when rosdep install has a problem? 2. After successfully rosmaking rgbdslam_eval, rgbdslam node cannot be found, is it because I edited manifest.xml by removing depend <eigen> 3. When i rosmake rgbdslam_eval successfully, I noticed that the bin folder inside rgbdslam_eval is empty, is this the place where a rgbdslam node is supposed to be? 4. How can I eventually make this thing to work ? Because after that I would like to try to evaluate my own recorded RGBD data.

Thank you for your time, and any help will be much appreciated.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-11-02 01:51:36.681557