Ask Your Question
0

How to subscribe hark_msgs types.

asked 2014-06-18 05:28:07 -0500

keshav_sarraf gravatar image

updated 2014-06-18 06:37:41 -0500

gvdhoorn gravatar image

i am using ROS Hydro in ubuntu 12.04. and I want to create a subscriber of hark_msgs. whenever I run a simple publisher designed in HARK from batchflow, I am able to view the messages in the terminal (using rostopic echo). When I am trying to create a subscriber ,I get this message:

Could not find a configuration file for package hark_msgs.

Set hark_msgs_DIR to the directory containing a CMake configuration file
for hark_msgs.  The file will have one of the following names:

hark_msgsConfig.cmake
hark_msgs-config.cmake

(whenever I include hark_msgs in the dependencies, I get the above error.)

I found the folder where hark_msg related (.msg) files are but .cmake files are no where to be seen. Any help would be appreciated.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-06-19 06:26:52 -0500

keshav_sarraf gravatar image

I created a rosbuild package to subscribe hark_msgs and it worked.

edit flag offensive delete link more
1

answered 2014-06-18 06:37:10 -0500

gvdhoorn gravatar image

updated 2014-06-18 08:19:27 -0500

Have you declared a dependency on hark_msgs in both your CMakeLists.txt and your package.xml? catkin needs that information to properly setup your include path(s).

See the Resolving dependencies section on the How to do common tasks page of the catkin documentation.


Edit: on second thought, the fact that you get that error message indicates that you are declaring a dependency, but that catkin / CMake cannot resolve it.

You say you "found the folder where hark_msg related (.msg) files are". Can you make sure that the package is on your package path? Does this work: rospack find hark_msgs?


Edit2: as far as I can tell hark_msgs is not a catkin package (ie: it is a 'dry' package), while your own package is a catkin package (ie: 'wet'). Wet packages cannot depend on dry packages, see Overlaying Dry and Wet Workspaces, which is why you are getting the error about catkin not being able to find the hark_msgs configuration file.

There is probably a manifest.xml file in the hark_msgs directory. Hydro should still be able to build dry packages (with rosbuild), so if you create a rosbuild package you should be able to use the hark stacks.

edit flag offensive delete link more

Comments

let me try converting it to catkin_package.

keshav_sarraf gravatar imagekeshav_sarraf ( 2014-06-18 07:07:36 -0500 )edit
0

answered 2014-06-19 01:45:47 -0500

130s gravatar image

I don't know where you're getting hark_msgs ROS package, but there's at least a catkinzied package jsk_hark_msgs. While it's in an organizational package suite (good'ol ***-ros-pkg manner), it should be able to be depended upon from any ROS package.

edit flag offensive delete link more

Comments

I installed Hark from the following link using apt-get : http://winnie.kuis.kyoto-u.ac.jp/HARK/wiki.cgi?page=HARK-ROS+Installation+Instructions But let me try with the package you mentioned

keshav_sarraf gravatar imagekeshav_sarraf ( 2014-06-19 02:08:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-06-18 05:28:07 -0500

Seen: 461 times

Last updated: Jun 19 '14