Rviz not displaying anything from kinect sensors [closed]

asked 2014-06-12 15:50:59 -0500

RThielstrom gravatar image

updated 2014-06-12 16:36:16 -0500

I'm currently trying to visualize information from the kinect camera in rviz and just nothing is showing up, not even the robot model (although checking "Collision Enabled" does produce a red-colored robot silhouette). Although things like Image and Camera say they are receiving images, they don't display them at all. Laser scan produces some incomprehensible flashing colored geometric planes across the grid (which I think is still wrong), but PointCloud, DepthCloud etc show nothing. I'm using hydro and following the ROS turtlebot tutorials.

Before opening rviz (with roslaunch turtlebot_bringup 3dsensor.launch) I run:

rosrun openni_camera openni_node

and

roslaunch turtlebot_bringup 3dsensor.launch

Both of which display the following warnings:

[ WARN] [1402603782.693472974]: Camera calibration file /home/turtlebot/.ros/camera_info/rgb_0000000000000000.yaml not found.
[ WARN] [1402603782.693805262]: Using default parameters for RGB camera calibration.
[ WARN] [1402603782.694144981]: Camera calibration file /home/turtlebot/.ros/camera_info/depth_0000000000000000.yaml not found.
[ WARN] [1402603782.694272849]: Using default parameters for IR camera calibration.

I've tried changing the fixed frame and it has no effect. Also, running

rosrun image_view image_view image:=/camera/rgb/image_color seems to work just fine and produces an image, despite the exact same image topic in rviz only producing a black screen.

Any ideas? I feel like it must be something very simple but I have no idea what I'm doing wrong.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-01-30 22:09:11.306836