Ask Your Question
0

catkin_pkg.package missing

asked 2014-06-12 12:09:14 -0600

JoSo gravatar image

updated 2014-06-12 18:29:37 -0600

Hi, I'm new to Ubuntu/Linux and I am trying to install ROS. I am following the instructions but run into a cmake error when I run catkin_make. Here's the output from that command. It seems that there are similar problems but I don't see the exact same error message in other posts. Any help would be appreciated and thanks in advance.

joroso2121@ubuntu:~/catkin_ws$ catkin_make
Base path: /home/joroso2121/catkin_ws
Source space: /home/joroso2121/catkin_ws/src
Build space: /home/joroso2121/catkin_ws/build
Devel space: /home/joroso2121/catkin_ws/devel
Install space: /home/joroso2121/catkin_ws/install
####
#### Running command: "cmake /home/joroso2121/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/joroso2121/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/joroso2121/catkin_ws/install" in "/home/joroso2121/catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/joroso2121/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /opt/ros/hydro
-- This workspace overlays: /opt/ros/hydro
-- Using PYTHON_EXECUTABLE: /usr/local/bin/python
-- Python version: 2.7
-- Using Debian Python package layout
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/joroso2121/catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
ImportError: "from catkin_pkg.package import parse_package" failed: No module named catkin_pkg.package
Make sure that you have installed "catkin_pkg", it is up to date and on the PYTHONPATH.
CMake Error at /opt/ros/hydro/share/catkin/cmake/safe_execute_process.cmake:11 (message):
  execute_process(/usr/local/bin/python
  "/opt/ros/hydro/share/catkin/cmake/parse_package_xml.py"
  "/opt/ros/hydro/share/catkin/cmake/../package.xml"
  "/home/joroso2121/catkin_ws/build/catkin/catkin_generated/version/package.cmake")
  returned error code 1
Call Stack (most recent call first):
  /opt/ros/hydro/share/catkin/cmake/catkin_package_xml.cmake:63 (safe_execute_process)
  /opt/ros/hydro/share/catkin/cmake/all.cmake:143 (_catkin_package_xml)
  /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:20 (include)
  CMakeLists.txt:52 (find_package)
-- Configuring incomplete, errors occurred!
Invoking "cmake" failed
joroso2121@ubuntu:~/catkin_ws$
edit retag flag offensive close merge delete

Comments

@JoSo please us the block quote functionality for readability, (highlight the text and press the 1010 button, or put 4 spaces in front of each line) I've done this for you.

tfoote gravatar imagetfoote ( 2014-06-12 12:50:56 -0600 )edit
1

I reverted back to the original Python that came with Ubuntu 13.04 and everything worked. I was able to go through the beginner's tutorials with success. Thanks. As a side note, my issues with opening the Rviz plugin with MOVEIT! also cleared. Heard on the block quote.

JoSo gravatar imageJoSo ( 2014-06-12 18:26:56 -0600 )edit

Great. Please accept the answer using the checkbox so others know your problem is solved.

tfoote gravatar imagetfoote ( 2014-06-12 18:52:18 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-06-12 13:02:35 -0600

tfoote gravatar image

Your problem is that you're missing the python module catkin_pkg. It looks like you're not using the system version of python. It looks like you have debian packages installed so you need to make sure that catkin_pkg is on your PYTHONPATH of your alternative python instance.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-06-12 12:09:14 -0600

Seen: 1,031 times

Last updated: Jun 12 '14