ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

freenect - Wrong scale in the PointCloud2? [closed]

asked 2014-06-10 08:57:17 -0600

Rabe gravatar image

Hey,

I am working on implementing a kinect in my robot-arm using MoveIt. I have an .urdf file with the kinect as a block hovering above the robot. I launch the freenect-node, perform a static transform from the TFs created by the freenect-node to my robot and visualize everything in Rviz.

My problem is, that the scale of the pointcloud2 is off, the distances are to small. At first I thought that a calibration of the camera wouldn't be necessary and that my robot model was off, but after measuring a couple of distances in Rviz as well as in the real world, it seems the error comes from the kinect.

My question is, where should I start to fix is and what is the common practice to calibrate? Is it normal, that the point-cloud is off (The object is 2m away from the kinect, the length according to the point cloud is about 10 cm shorter than the actual length), or shouldn't the kinect be calibrated from the factory?

I am using freenect launch version 0.3.2 with ROS hydro on Ubuntu 12.04.

Thanks in advance,

Rabe

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Rabe
close date 2014-06-12 02:15:20.148422

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-06-12 02:14:45 -0600

Rabe gravatar image

Sooo, after calibrating the RGB and the IR camera like described here, nothing changed. I didn't expect it to work anyway. Luckily, I tried a Asus Xtion with the same setup, which worked flawlessly. This means that the error is in my kinect. I guess I'll have to find a way to recalibrate it.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-06-10 08:57:17 -0600

Seen: 382 times

Last updated: Jun 12 '14