Ask Your Question
0

Save a map with Lidar

asked 2014-06-02 22:26:34 -0600

guigui gravatar image

I follow this tutorial for save a map : http://wiki.ros.org/slam_gmapping/Tut... I create my own bag, and i see on rviz the Lidar data. But when I launch the command " rosrun gmapping slam_gmapping scan:=base_scan " there are nothing on my terminal. is normal? After that, I wrote "rosbag play --clock nameofmybag.bag" --->>> it's done, and " rosrun map_server map_saver". On my terminal, there are writing "waiting for de map" but nothing after that. What's the problem?

(When i launch the last command, in my another terminal " rosrun gmapping .." they are write : TF_OLD_DATA ignoring data from the past for frame base_footprint at time .... )

Thanks for your Help

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-06-02 23:36:01 -0600

fergs gravatar image

updated 2014-06-02 23:37:33 -0600

TF_OLD_DATA probably means that you have not set sim time to true. When playing back bagfiles, you have to use sim time so that the clock published by rosbag will be used by nodes that need to interact with time:

rosparam set use_sim_time true

This should be run after starting your roscore, but BEFORE starting gmapping or rosbag

edit flag offensive delete link more
0

answered 2014-06-03 00:00:31 -0600

guigui gravatar image

updated 2014-06-03 00:01:31 -0600

Yes I had run "rosparam set use_sim_time true " after roscore and before gmapping and rosbag. I follow exactly the tutorial. It's the same problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-06-02 22:26:34 -0600

Seen: 302 times

Last updated: Jun 03 '14