ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

catkin_make carries out all processes

asked 2014-05-26 20:06:25 -0500

moyashi gravatar image

When catkin_make is carried out twice in a row,
I believe that the second catkin_make finishes instantaneously if the first one is done successfully.

However, I have the following situations.

  1. do catkin_make and it's done successfully
  2. do catkin_make in a row(nothing is edited.)
  3. "make" is started from the beginning(it's strange) and takes a lot of time.
  4. do catkin_make and have the same situation as "3".

What's the matter ??

Thanks in advance.

Configuration :
OS : Ubuntu 12.04LTS
ROS : Hydro
Packages in catkin workspace :
some original packages,
navigation metapackage(amcl, move_base and so on),
kobuki(kobuki-hydro, kobuki_core-hydro kobuki_msgs),
turtlebot(turtlebot_apps, turtlebot_bringup, turtlebot_description, turtlebot_msgs, turtlebot_simulator, turtlebot_viz, yocs_msgs-hydro, yujin_ocs, joystic_drivers, linux_hardware)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-26 20:33:32 -0500

ahendrix gravatar image

Usually, a second run of catkin_make after the first run completed successfully should NOT re-run cmake, and shouldn't rebuild anything. You will still see status messages as it checks the dependencies to make sure everything is up to date, but even in large projects, this should only take a few seconds.

I have seen a few cases where targets or dependencies were specified improperly, causing them to rebuild every time, and this caused all of the dependencies to rebuild as well.

Most commonly I've seen this happen when the output files for a dynamic_reconfigure cfg file didn't match the name of the cfg file, but it can also happen if you have custom targets that don't produce the right files, or custom targets that create directories and then place files in them as part of the build process.

edit flag offensive delete link more

Comments

Thank you for your answer and I solved the problem.
I checked dependencies, but found no mistake.
In my case, build time was wrong. My laptop had U.S time, but it has Tokyo's time now.
I removed catkin_ws/build and catkin_ws/devel, tried the above procedures and catkin_make worked well.

moyashi gravatar image moyashi  ( 2014-05-27 13:46:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-05-26 20:06:25 -0500

Seen: 155 times

Last updated: May 26 '14