Ask Your Question
1

installation groovy on fedora, rosdep error (Cannot locate rosdep definition for [orocos_kdl])

asked 2014-05-25 10:15:54 -0500

BP gravatar image

updated 2014-06-19 07:18:33 -0500

I am following instalation guide (with slightly changes described on generic source installation.

After:

 i@C3PO catkin_ws]$ rosdep install --from-paths src --ignore-src --rosdistro groovy -y

I get:

WARNING: Metapackage "diagnostics" must buildtool_depend on catkin.
ERROR: the following packages/stacks could not have their rosdep keys resolved
to system dependencies:
tf2_geometry_msgs: Cannot locate rosdep definition for [orocos_kdl]
kdl_parser: Cannot locate rosdep definition for [orocos_kdl]
tf2_kdl: Cannot locate rosdep definition for [orocos_kdl]
kdl_conversions: Cannot locate rosdep definition for [orocos_kdl]
eigen_conversions: Cannot locate rosdep definition for [orocos_kdl]

What can I do to resolve this problem?

// edit 1: cant do

rosinstall_generator orocos_kdl --rosdistro groovy --deps --wet-only > orocos_kdl.rosinstall

I get

The following not released packages/stacks will be ignored: orocos_kdl No packages/stacks left after ignoring not released

edit 2. I feel i'll have to install Ubuntu, sadly

edit retag flag offensive close merge delete

Comments

There seems to be a general problem on groovy with orcos_kdl for the source install. This will be the same on Ubuntu (though the install from deb will likely work). Any reason you need to use groovy and not hydro?

demmeln gravatar image demmeln  ( 2014-06-19 08:09:15 -0500 )edit

I don't need orocos_kdl but sth. requires it at ros installation stage. I wanted groovy to have same ros distro on pc and robot, but I've installed additionally Ubuntu to make things easier.

BP gravatar image BP  ( 2014-06-19 13:22:11 -0500 )edit

Makes sense. I openend an issue about this problem: https://github.com/ros/rosdistro/issues/4792

demmeln gravatar image demmeln  ( 2014-06-19 17:35:46 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-06-17 16:32:56 -0500

demmeln gravatar image

It seems that orocos_kdl is not released into groovy. You could ask the author to release it for groovy over at https://github.com/orocos/orocos_kine... , or use hydro instead.

Alternatively, you can try also try to use the hydro version of just orocos_kdl and see if that works.

rosinstall_generator orocos_kdl --rosdistro hydro --wet-only > orocos_kdl.rosinstall
wstool merge -t src orocos_kdl.rosinstall
wstool up -t src
edit flag offensive delete link more
0

answered 2014-05-25 10:27:37 -0500

ahendrix gravatar image

It looks like your wstool step didn't download the orocos_kdl package for some reason.

You should be able to add it to your workspace by doing something like:

rosinstall_generator orocos_kdl --rosdistro groovy --deps --wet-only > orocos_kdl.rosinstall
wstool merge -t src orocos_kdl.rosinstall
wstool up -t src
edit flag offensive delete link more

Comments

The following not released packages/stacks will be ignored: orocos_kdl No packages/stacks left after ignoring not released

BP gravatar image BP  ( 2014-06-16 15:38:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-25 10:15:54 -0500

Seen: 818 times

Last updated: Jun 19 '14