Problems managing workspace and ROS_PACKAGE_PATH [closed]

asked 2014-05-15 20:59:31 -0600

hvn gravatar image

Hi,

I have set up ROS Hydro and use packages created with Electric. Since I can keep using rosbuild with Hydro, I stick to it. By sourcing /opt/ros/hydro/setup.bash I have a ROS_PACKAGE_PATH that is /opt/ros/hydro/share:/opt/ros/hydro/stacks. Now, when I add my workspace to this path using rosws, it tells me that the update is complete. Then I source the workspace setup.bash and echo the path again, only to find that the workspace has not been added. What could I be doing wrong ?

Thanks.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-01-30 20:56:56.062360

Comments

Try adding it simply by executing this command: export ROS_PACKAGE_PATH= /opt/ros/hydro/share:/opt/ros/hydro/stacks:/path/to/your/ws Does this work?

AbuIbra gravatar image AbuIbra  ( 2014-05-15 23:21:45 -0600 )edit

It works in the sense that the workspace is added to the path, but roscd doesn't know or recognize any of my packages.

hvn gravatar image hvn  ( 2014-05-16 01:02:59 -0600 )edit

So did you use rosws init and then rosws set? As described here: http://wiki.ros.org/ROS/Tutorials/InstallingandConfiguringROSEnvironment

delta785 gravatar image delta785  ( 2014-05-25 09:55:00 -0600 )edit

Yes, I certainly did.

hvn gravatar image hvn  ( 2014-05-25 10:53:15 -0600 )edit