Ask Your Question
0

rosmake rgbdslam

asked 2014-05-11 17:19:06 -0600

360693047 gravatar image

when I rosmake rgbdslam_freiburg,my cpu use rate achives 100%,which causes my computer crashed, and the make dosent complete.I use ubuntu 64 and my computer is 4G memory.

edit retag flag offensive close merge delete

Comments

no idea. but maybe you can try catkin_make. copy rgbdslam_freiburg to your catkin home's src sub dir. run catkin_make at catkin home dir

vdonkey gravatar imagevdonkey ( 2014-05-11 18:08:34 -0600 )edit

Do you run out of memory? Are you overheating?

tfoote gravatar imagetfoote ( 2014-05-11 19:29:51 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-26 23:41:40 -0600

Check if you have parallel compilation enabled, e.g. in the environment variable $ROS_PARALLEL_JOBS (also there will be multiple compiler processes in "top" when you run rosmake).

4GB might not be enough if you do compile in parallel, as some very memory hungry template libraries are used.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-05-11 17:19:06 -0600

Seen: 137 times

Last updated: May 26 '14