Ask Your Question
0

Hector_quadrotor doesn't respond to "rostopic pub" command

asked 2014-05-06 11:16:32 -0500

Robert1 gravatar image

Hi Everyone, I installed the hector_quadrotor package from source then I ran "roslaunch hector_quadrotor_demo indoor_slam_gazebo" Finally, I tried to input command velocity using the "rostopic pub" but the quadrotor doesn't respond to the command velocity. I verified via "rqt_graph" that gazebo is connected to the correct topic (/cmd_vel ) and via "rostopic echo /cmd_vel" that data is published to the right topic. I am using 1.9Gazebo&Gazebo-ROS-packs and hydro ROS installed from binaries for this simulation.

Thank you for any help with this issue

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-08 14:15:30 -0500

Robert1 gravatar image

I found my mistake. The motor engine didn't start since i didn't provide positive linear velocity on the "z" direction. Now it is flying.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-05-06 11:16:32 -0500

Seen: 177 times

Last updated: May 08 '14