Ask Your Question
1

[SOLVED] Rviz 2D Nav Goal/Pose Estimate do not work

asked 2014-05-04 20:48:13 -0500

aviprobo gravatar image

updated 2014-05-05 14:38:43 -0500

Hey everyone,

We've seem to run into a problem just earlier this week. For the past 8 months we were able to send 2d nav goals and set the 2d initial pose using Rviz perfectly fine. We are usin ROS Fuerte. Just earlier this week, we are not able to do this anymore at all. When I send the 2d nav goal, it's not getting published to the rostopic and hence, nothing seems to happen. I cannot even set the initial 2d pose estimate. We've tried reinstalling the visualization packages and still no luck at all.

Could anyone please suggest any solutions? Many thanks!

EDIT: We've solved the issue. Turns out the ROS_HOSTNAME on the workstation was incorrect.

edit retag flag offensive close merge delete

Comments

Check whether correct topics are set for Rviz tools. Goto Panel -> Tool properties.

prince gravatar imageprince ( 2014-05-05 01:59:38 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-08-19 03:18:51 -0500

Markus Bader gravatar image

Hi

Adding the comptuername to the /etc/hosts on both client and server solves many problems.

;-)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-04 20:48:13 -0500

Seen: 965 times

Last updated: Aug 19 '14