Ask Your Question
0

Bad orocos_kdl version with robot_state_publisher

asked 2014-05-01 14:35:57 -0500

Seeing this on a Hydro install:

process[robot_state_publisher-7]: started with pid [17121]
/opt/ros/hydro/lib/robot_state_publisher/state_publisher: error while loading shared libraries: liborocos-kdl.so.1.1: cannot open shared object file: No such file or directory
No handlers could be found for logger "roslaunch"
[robot_state_publisher-7] process has died [pid 17121, exit code 127, cmd /opt/ros/hydro/lib/robot_state_publisher/state_publisher __name:=robot_state_publisher __log:=/tmp/8ca25758-d179-11e3-85e3-0001c0118a71/robot_state_publisher-7.log].
log file: /tmp/8ca25758-d179-11e3-85e3-0001c0118a71/robot_state_publisher-7*.log

Both ros-hydro-orocos-kdl and ros-hydro-robot-state-publisher claim to be up-to-date, so I'm not quite sure what's going on.

$ ls -1 /opt/ros/hydro/lib/liboroco*
/opt/ros/hydro/lib/liborocos-bfl.so
/opt/ros/hydro/lib/liborocos-kdl.so
/opt/ros/hydro/lib/liborocos-kdl.so.1.2
/opt/ros/hydro/lib/liborocos-kdl.so.1.2.1
$ sudo apt-get install ros-hydro-robot-state-publisher
Reading package lists... Done
Building dependency tree
Reading state information... Done
ros-hydro-robot-state-publisher is already the newest version.

Thoughts what's going on here?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2014-05-01 21:47:19 -0500

This is the same error that is described in robot_state_publisher issue #11. You might want to check the versions you´re using with the commands stated there. I remember encountering this problem a few months ago, too. But updating packages has since fixed it for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-01 14:35:57 -0500

Seen: 420 times

Last updated: May 01 '14