ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Error in building face_recognition package

asked 2014-04-17 03:31:44 -0500

Eman gravatar image

updated 2016-10-24 09:03:08 -0500

ngrennan gravatar image

In tutorials of face_recognition I downloaded the face_recognition package from Github but when I build the package using the command rosmake face_recognition ,I had the following error .

[ rosmake ] rosmake starting...                                                                                                                
[ rosmake ] Packages requested are: ['face_recognition']                                                                                       
[ rosmake ] Logging to directory /home/smart-engineers/.ros/rosmake/rosmake_output-20140417-150308                                             
[ rosmake ] Expanded args ['face_recognition'] to:
[rosmake-0] Starting >>> catkin [ make ]                                                                                                       
[rosmake-0] Finished <<< catkin ROS_NOBUILD in package catkin
 No Makefile in package catkin                                                   
[rosmake-0] Starting >>> genmsg [ make ]                                                                                                       
[rosmake-3] Starting >>> console_bridge [ make ]                                                                                               
[rosmake-0] Finished <<< genmsg ROS_NOBUILD in package genmsg
 No Makefile in package genmsg                                                   
[rosmake-0] Starting >>> genlisp [ make ]                                                                                                      
[rosmake-3] Finished <<< console_bridge ROS_NOBUILD in package console_bridge
 No Makefile in package console_bridge                           
[rosmake-1] Starting >>> genpy [ make ]                                                                                                        
[rosmake-2] Starting >>> gencpp [ make ]                                                                                                       
[rosmake-3] Starting >>> cpp_common [ make ]                                                                                                   
[rosmake-0] Finished <<< genlisp ROS_NOBUILD in package genlisp
 No Makefile in package genlisp                                                
[rosmake-0] Starting >>> rospack [ make ]                                                                                                      
[rosmake-3] Finished <<< cpp_common ROS_NOBUILD in package cpp_common
 No Makefile in package cpp_common                                       
[rosmake-3] Starting >>> rostime [ make ]                                                                                                      
[rosmake-1] Finished <<< genpy ROS_NOBUILD in package genpy
 No Makefile in package genpy                                                      
[rosmake-2] Finished <<< gencpp ROS_NOBUILD in package gencpp
 No Makefile in package gencpp                                                   
[rosmake-0] Finished <<< rospack ROS_NOBUILD in package rospack
 No Makefile in package rospack                                                
[rosmake-0] Starting >>> roslib [ make ]                                                                                                       
[rosmake-1] Starting >>> message_generation [ make ]                                                                                           
[rosmake-2] Starting >>> roslang [ make ]                                                                                                      
[rosmake-3] Finished <<< rostime ROS_NOBUILD in package rostime
 No Makefile in package rostime                                                
[rosmake-0] Finished <<< roslib ROS_NOBUILD in package roslib
 No Makefile in package roslib                                                   
[rosmake-0] Starting >>> rosunit [ make ]                                                                                                      
[rosmake-3] Starting >>> roscpp_traits [ make ]                                                                                                
[rosmake-1] Finished <<< message_generation ROS_NOBUILD in package message_generation
 No Makefile in package message_generation               
[rosmake-2] Finished <<< roslang ROS_NOBUILD in package roslang
 No Makefile in package roslang                                                
[rosmake-2] Starting >>> xmlrpcpp [ make ]                                                                                                     
[rosmake-0] Finished <<< rosunit ROS_NOBUILD in package rosunit
 No Makefile in package rosunit                                                
[rosmake-0] Starting >>> rosgraph [ make ]                                                                                                     
[rosmake-2] Finished <<< xmlrpcpp ROS_NOBUILD in package xmlrpcpp
 No Makefile in package xmlrpcpp                                             
[rosmake-1] Starting >>> rosclean [ make ]                                                                                                     
[rosmake-2] Starting >>> opencv2 [ make ]                                                                                                      
[rosmake-3] Finished <<< roscpp_traits ROS_NOBUILD in package roscpp_traits
 No Makefile in package roscpp_traits                              
[rosmake-3] Starting >>> roscpp_serialization [ make ]                                                                                         
[rosmake-0] Finished <<< rosgraph ROS_NOBUILD in package rosgraph
 No Makefile in package rosgraph                                             
[rosmake-2] Finished <<< opencv2 ROS_NOBUILD in package opencv2
 No Makefile in package opencv2                                                
[rosmake-2] Starting >>> rosmaster [ make ]                                                                                                    
[rosmake-0] Starting >>> rosparam [ make ]                                                                                                     
[rosmake-3] Finished <<< roscpp_serialization ROS_NOBUILD in package roscpp_serialization
 No Makefile in package roscpp_serialization         
[rosmake-3] Starting >>> message_runtime [ make ]                                                                                              
[rosmake-1] Finished <<< rosclean ROS_NOBUILD in package rosclean
 No Makefile in package rosclean                                             
[rosmake-0] Finished <<< rosparam ROS_NOBUILD in package rosparam
 No Makefile in package rosparam                                             
[rosmake-1] Starting >>> class_loader [ make ]                                                                                                 
[rosmake-3] Finished <<< message_runtime ROS_NOBUILD in package message_runtime
 No Makefile in package message_runtime                        
[rosmake-2] Finished <<< rosmaster ROS_NOBUILD in package rosmaster
 No Makefile in package rosmaster                                          
[rosmake-3] Starting >>> std_msgs [ make ]                                                                                                     
[rosmake-0] Starting >>> rosbuild [ make ]                                                                                                     
[rosmake-3] Finished <<< std_msgs ROS_NOBUILD in package std_msgs
 No Makefile in package std_msgs                                             
[rosmake-1] Finished <<< class_loader ROS_NOBUILD in package class_loader
 No Makefile in package class_loader                                 
[rosmake-3] Starting >>> rosgraph_msgs [ make ]                                                                                                
[rosmake-0] Finished <<< rosbuild ROS_NOBUILD in package rosbuild
 No Makefile in package rosbuild                                             
[rosmake-1] Starting >>> actionlib_msgs [ make ]                                                                                               
[rosmake-0] Starting >>> rosconsole [ make ]                                                                                                   
[rosmake-2] Starting >>> geometry_msgs [ make ]                                                                                                
[rosmake-1] Finished <<< actionlib_msgs ROS_NOBUILD in package actionlib_msgs
 No Makefile in package actionlib_msgs                           
[rosmake-3] Finished <<< rosgraph_msgs ROS_NOBUILD in package rosgraph_msgs
 No Makefile in package rosgraph_msgs ...
edit retag flag offensive close merge delete



rosmake says you the cause of the error: It hasn't the permissions to create the 'build' directory. Where did you create your rosmake workspace? What are the permissions of the face_recognition package? face_recognition is currently not in the debians, so you can't install it with apt-get atm.

BennyRe gravatar image BennyRe  ( 2014-04-17 03:42:12 -0500 )edit

The face_recognition package is in the src folder of catkin_WS . The catkin_WS is in the home.When I tried to type " rospack find face_recognition ", it returned the path of the package,so this mean that ROS can see the package.

Eman gravatar image Eman  ( 2014-04-17 03:51:23 -0500 )edit

Ah ok, so you are using rosbuild inside the catkin workspace. I know some people do this. I personally always used rosbuild on groovy and late like this:

BennyRe gravatar image BennyRe  ( 2014-04-17 03:56:17 -0500 )edit

Excuse me, when I transfered this package to the file system/opt/ros/hydro/share using the command " sudo cp -r " , it has been transferred successfully to /opt/ros/hydro/share. but when I tried to build it using " rosmake face_recognition " , I had the same error

Eman gravatar image Eman  ( 2014-04-17 04:06:17 -0500 )edit

Using the command " sudo apt-get install " to install packages, it downloaded the packages in filesystem/opt/ros/hydro/share, So, I tried the same concept using the command " sudo cp-r ", so what is the error ??

Eman gravatar image Eman  ( 2014-04-17 04:11:02 -0500 )edit

Hello @Eman, Do you look for this page ( )? I have never used this package people, but this page includes face_detector package. Do you try to install it with sudo apt-get install ros-***-people ? If you don't need it, please remove it.

Ken_in_JAPAN gravatar image Ken_in_JAPAN  ( 2014-04-17 08:12:31 -0500 )edit

@BennyRe Thanks a lot for your help.

Eman gravatar image Eman  ( 2014-04-21 11:13:03 -0500 )edit

@Ken_in_JAPAN Thanks a lot for your help.

Eman gravatar image Eman  ( 2014-04-21 11:13:45 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-04-18 01:39:05 -0500

demmeln gravatar image

updated 2014-04-18 08:53:36 -0500

You should not copy uour package to /opt/ros/hydro/share ! You get this error because the the package folder is now likely owned by root and not writable by you. As a rule of thumb you should never manually edit anything underneath /opt/ros.

Remove anything you added to /opt/ros/hydro/share , create a rosbuild workspace (ontop the base install, or ontop of your catkin workspace, see ), add the source to that workspace and try again with rosmake.

Edit: Maybe the face_detector package from as suggested by @Ken_in_JAPAN is a better choice, because it is a catkin package released into hydro and can even be installed via APT. I have no idea how the two packages compare functionality wise, though.

edit flag offensive delete link more


@demmeln, I agree to your answer. I'm sorry. I post my comment before reading his comment. I missed his article that he download the package in /opt/ros/hydro/share.

Ken_in_JAPAN gravatar image Ken_in_JAPAN  ( 2014-04-18 07:47:03 -0500 )edit

@demmeln Thanks a lot for your help. How can I remove this package from /opt/ros/hydro/share ,please?? Is there a command to do that ??

Eman gravatar image Eman  ( 2014-04-21 11:20:29 -0500 )edit

Didn't you say you moved the files manually with `sudo cp -r`? You remove the files you added (e.g. with the `rm` command, but be very careful not to delete something else accidentally with `sudo rm -r`.

demmeln gravatar image demmeln  ( 2014-04-21 12:14:45 -0500 )edit

Thanks for your help.

Eman gravatar image Eman  ( 2014-04-21 12:36:24 -0500 )edit

Question Tools


Asked: 2014-04-17 03:31:44 -0500

Seen: 318 times

Last updated: Apr 18 '14