Ask Your Question

Can't Install ros-hydro-desktop-full from USB stick

asked 2014-04-16 14:53:33 -0600

billtecteacher gravatar image

updated 2016-10-24 08:36:52 -0600

ngrennan gravatar image

Trying to setup a USB stick with ROS for a student. Get to the following command and I get this error:

ubuntu@ubuntu:~$ sudo apt-get install ros-hydro-desktop-full Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-hydro-desktop-full : Depends: ros-hydro-desktop but it is not going to be installed Depends: ros-hydro-mobile but it is not going to be installed Depends: ros-hydro-perception but it is not going to be installed Depends: ros-hydro-simulators but it is not going to be installed E: Unable to correct problems, you have held broken packages. ubuntu@ubuntu:~$

Am using UBUNTU 12.04 Live and UNETBOOTIN loader.

Was wondering how to proceed to fix it?


edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2014-04-16 16:06:30 -0600

billtecteacher gravatar image

Never mind just answered my own comment shoud be sudo apt-get install aptitude not installed by default on 12.04

edit flag offensive delete link more

answered 2014-04-16 15:27:50 -0600

ahendrix gravatar image

This is the package manager complaining that it can't find the dependencies for ROS for some reason.

aptitude is better at resolving these things sometimes; try running:

sudo aptitude install ros-hydro-desktop-full

But be careful to read the solutions that it proposes; sometimes they can involve removing or downgrading other packages that you have installed, which may not be what you want.

edit flag offensive delete link more


ubuntu@ubuntu:~$ sudo aptitude install ros-hydro-desktop-full sudo: aptitude: command not found ubuntu@ubuntu:~$ sudo apt-get aptitude E: Invalid operation aptitude ubuntu@ubuntu:~$ How does one get aptitude on to system?

billtecteacher gravatar imagebilltecteacher ( 2014-04-16 16:01:21 -0600 )edit

aptitude was not able to resolve dependencies

billtecteacher gravatar imagebilltecteacher ( 2014-04-16 16:24:03 -0600 )edit

I suspect aptitude gave you different errors; can you add those to your question?

ahendrix gravatar imageahendrix ( 2014-04-16 16:52:43 -0600 )edit

Just started today looking into debian packages. There is a lot to the package system that I always took for granted because it worked for me. There are 300 + packages not getting installed including collida and on down the list. If I put a more to see the first part of the command I get the following and it returns to prompt after this instead of sending a ton of messages to the screen: ubuntu@ubuntu:~$ sudo aptitude install ros-hydro-desktop-full | more E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it? Reading package lists... Building dependency tree... Reading state information... Reading extended state information... Initializing package states... E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg ...(more)

billtecteacher gravatar imagebilltecteacher ( 2014-04-17 06:02:08 -0600 )edit

The lock file in last post for some reason was left with a permission which killed the script. I can fix the lock permission and it goes back to error with list of 300+ packages not installed. I think I can learn more myself diving into aptitude command thanks to you.

billtecteacher gravatar imagebilltecteacher ( 2014-04-17 06:18:20 -0600 )edit

Yeah, there's quite a bit to the package manager. It may be worth confirming that you have the `restricted`, `universe` and `multiverse` repositories enabled.

ahendrix gravatar imageahendrix ( 2014-04-17 06:27:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-04-16 14:53:33 -0600

Seen: 309 times

Last updated: Apr 16 '14