Ask Your Question
0

How to start gscam in groovy/hydro ?

asked 2014-04-16 03:25:41 -0500

hvn gravatar image

Hi,

There seems to be conflicting info about how to start and use gscam. http://wiki.ros.org/gscam states to go to the bin/ directory but http://answers.ros.org/question/91676... mentions something entirely different. Also, when trying, I find that ~/.ros/camera_info doesn't exist. Shouldn't this be installed with gscam ?

Thanks

edit retag flag offensive close merge delete

Comments

Hi, it doesn't matter if you don't have your bin or the camera_info folder. Did you tried something and get errors?

RosFaceNoob gravatar imageRosFaceNoob ( 2014-04-16 05:50:00 -0500 )edit

Yes, I did. I exported GSCAM_CONFIG, started "rosrun gscam gscam". Got the messages that it can't open the camera calibration file and that camera.yaml isn't found. It does start the stream but "rostopic list" doesn't show any /gscam topics.

hvn gravatar imagehvn ( 2014-04-16 06:53:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-16 21:41:22 -0500

RosFaceNoob gravatar image

updated 2014-04-16 21:41:55 -0500

You have that warning because you didn't calibrate your camera. It's not an error, it's just a warning so you can still run your gscam. You won't have any /gscam topics, but something like /camera/camerainfo /camera/image_raw. Do you have something like that?

edit flag offensive delete link more

Comments

I did have those topics, now it's failing for some reason so have to figure out why. Ok, had wrong framerate. So have those topics again.

hvn gravatar imagehvn ( 2014-04-16 22:50:41 -0500 )edit

So your gscam is running. Do you have other problems?

RosFaceNoob gravatar imageRosFaceNoob ( 2014-04-16 23:02:01 -0500 )edit

OK, what's wrong with "rosrun image_view image_view image:=/camera/image_raw" that I get "Illegal instruction (core dumped)" ?

hvn gravatar imagehvn ( 2014-04-16 23:11:42 -0500 )edit

what did you put in your GSCAM_CONFIG? make sure your device is the good one

RosFaceNoob gravatar imageRosFaceNoob ( 2014-04-16 23:29:33 -0500 )edit

If you mean like device=/dev/video0, yes it is. The whole GSCAM_CONFIG="v4l2src device=/dev/video0 ! video/x-raw-rgb,framerate=25/1 ! ffmpegcolorspace"

hvn gravatar imagehvn ( 2014-04-16 23:57:00 -0500 )edit

try GSCAM_CONFIG="v4l2src device=/dev/video0 ! video/x-raw-rgb ! ffmpegcolorspace"

RosFaceNoob gravatar imageRosFaceNoob ( 2014-04-17 02:13:54 -0500 )edit

same result

hvn gravatar imagehvn ( 2014-04-17 02:53:13 -0500 )edit

OK, found out why it gives Illegal instruction. It seems that the AMD cpu can't handle (part of) rosrun.

hvn gravatar imagehvn ( 2014-04-19 21:19:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-16 03:25:41 -0500

Seen: 257 times

Last updated: Apr 16 '14