Ask Your Question
0

problem publishing with rosbridge suite

asked 2014-04-09 23:29:58 -0500

Anis Koubaa gravatar image

Hello,

I have run this tutorial (I am using ROS Hydro) wiki.ros.org/rosbridge_suite/Tutorials/RunningRosbridge on running rosbridge example.

When I started the HTML page, I noticed that all work expect publishing the /cmd/vel topic. I am getting this error message

[ERROR] [WallTime: 1397113517.026746] [Client 4] [id: advertise:/cmd_vel:1] advertise: __init__() got an unexpected keyword argument 'queue_size'

[ERROR] [WallTime: 1397113517.035466] [Client 4] [id: publish:/cmd_vel:2] publish: Cannot infer topic type for topic /cmd_vel as it is not yet advertised

Do you have any idea how to fix this issue?

I tested the same code on another Hydro machine and it worked, but on my machine with the same configuration, I had the error above.

Thank you in advance

edit retag flag offensive close merge delete

Comments

Can you share the rosbridge package version and HTML code you tested?

jihoonl gravatar image jihoonl  ( 2014-04-12 19:23:59 -0500 )edit

I will check the problem sometime tommorrow

jihoonl gravatar image jihoonl  ( 2014-04-25 21:41:18 -0500 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2014-05-21 23:22:47 -0500

jihoonl gravatar image

updated 2014-05-21 23:23:21 -0500

Refer to the github issue in rosbridge_suite. It was because incompatibility in rospy between groovy and hydro. Groovy version of rosbridge_suite has been re-released and should not have this error as of now.

edit flag offensive delete link more
0

answered 2014-04-29 05:33:19 -0500

jalfonso gravatar image

updated 2014-05-19 00:27:57 -0500

I got same error in Ubuntu 12.04 and groovy. The solution is to use an overlay with an older version that works, the version 3.5 of the groovy-devel branch in github.

This are the instructions to get the old version. I assume you had created and sourced an overlay.

In a terminal..

roscd

cd ../src

git clone https://github.com/RobotWebTools/rosb... -b groovy-devel

cd rosbridge_suite

git reset --hard da51ab060ec74d7c026bf3f1dbb2bde76d55d0b9

cd ../..

catkin_make

edit flag offensive delete link more
0

answered 2014-04-25 05:42:54 -0500

peterpolidoro gravatar image

I am running into a similar problem. I am running Groovy on Ubuntu 12.04. I just apt-get upgraded my ros-groovy packages (to version 0.5.4-0precise-20140417-0429-+0000) and now code that used to work fine is suddenly broken. I am simply publishing an empty message on a topic from javascript using roslibjs (revision 6) and subscribing with a smach_ros.MonitorState. I get the error: "__init__() got an unexpected keyword argument 'queue_size'". Would love some ideas for how to fix this. Is it an issue with roslibjs or rosbridge? What can I change to make this work again?

edit flag offensive delete link more
0

answered 2014-04-28 18:59:33 -0500

Anis gravatar image

For my case, I just made a fresh installation of Hydro and everything worked fine after re-installation.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-04-09 23:29:58 -0500

Seen: 1,924 times

Last updated: May 21 '14