ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

install ros hydro on raspberry pi [closed]

asked 2014-04-08 03:19:19 -0500 gravatar image

I'm new in ros and I'm trying to install ros hydro on raspberry pi, but if I write this command "rosdep install - src-paths from - ignore-src - rosdistro hydro-y - os = debian: wheezy " I get E: unable to locate package ros-hydro-xmlrpcpp ERROR: The following rosdeps failed to install apt: command [sudo apt-get install ros-y-hydro-xmlrpcpp] failed i don't know what is the problem

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2014-10-22 18:57:30.154640

2 Answers

Sort by ยป oldest newest most voted

answered 2014-04-10 06:21:27 -0500 gravatar image

thank you for your answer, i use the tutorial in this website ( and I'm trying the next command: "sudo sh -c 'echo "deb raring main" > /etc/apt/sources.list.d/ros-latest.list ' " and all the others command but if i try: "rosdep install - src-paths from - ignore-src - rosdistro hydro-y - os = debian: wheezy " I get the same error... please I need your answer.

edit flag offensive delete link more

answered 2014-04-09 07:44:16 -0500

Ken_in_JAPAN gravatar image

updated 2014-04-10 07:29:36 -0500

Excuse me, Which website did you look at? Did you check a web ( )? Did you try it from beginning of instruction? If you miss install dependencies, please try it. I think that the error message (E: unable to locate package ros- **) says that you don't try the next command

sudo sh -c 'echo "deb raring main" > /etc/apt/sources.list.d/ros-latest.list'

I want you to pay attention to raring of the command. As you know, raring is Ubuntu 13.04. Please check your environment. I hope that my advice is useful for you.

Do you try the next command?

 apt-cache search ros-hydro-xmlrpcpp

I think that package ros-hydro-xmlrpcpp exists on ROS, but there is not ros-y-hydro-xmlrpcpp, isn't it.

edit flag offensive delete link more


thank you, I try this command and i get the same error. Really, i don't know what i do ? I spent a lot of time in this step. gravatar image  ( 2014-04-10 22:24:00 -0500 )edit

Question Tools


Asked: 2014-04-08 03:19:19 -0500

Seen: 534 times

Last updated: Apr 10 '14