Ask Your Question
0

Very slow when rviz the kinect

asked 2014-04-01 08:51:08 -0500

pinocchio gravatar image

updated 2016-10-24 08:36:42 -0500

ngrennan gravatar image

Hi guys, I am using ROS hydro for kinect. When I use rviz to show the point clouds (unregistered and registered), the window turns very slow. The display can response even two or three seconds. Could anyone give me some suggestions to fix this problem? Many thanks.

edit retag flag offensive close merge delete

Comments

Can I know your machine specification? Graphic card performance is very important to view point cloud.

byeongkyu gravatar image byeongkyu  ( 2014-04-01 16:35:07 -0500 )edit

Could you explain more detail? For example, with multi machine or with single machine? In case of multi machine, we can guess a problem on network. In case of single machine, we can guess a problem on graphic card as Mr. byeongkyu says.

Ken_in_JAPAN gravatar image Ken_in_JAPAN  ( 2014-04-01 18:05:20 -0500 )edit

Also, did you compile rviz from source, or did you install it with apt?

demmeln gravatar image demmeln  ( 2014-04-02 02:53:25 -0500 )edit

@byeongkyu@Ken_in_JAPAN@demmeln Hi guys, thanks for you help. I am using single machine for rviz, and rviz is installed with hydro by default. I think it is installed with apt. The computer's detailed information: Processor: Intel(R) Core(TM) i5 CPU U 540 @ 1.20GHz (4 CPUs), ~1.2GHz Memory: 8192MB RAM Display: Name: Intel(R) HD Graphics Chip Type: Intel(R) HD Graphics (Core i5) DAC Type: Internal

pinocchio gravatar image pinocchio  ( 2014-04-02 04:16:16 -0500 )edit

@pinocchio: Installing from apt should be ok. If installing from source, you might get bad performance if your forget to set the CMAKE_BUILD_TYPE to Release. Not sure if this should be faster on your machine.

demmeln gravatar image demmeln  ( 2014-04-02 04:47:11 -0500 )edit
1

@pinocchio: It is recommend that upgrade your graphic card, and set your cpufreq to performance mode.

byeongkyu gravatar image byeongkyu  ( 2014-04-02 20:38:40 -0500 )edit

Have you solved this problem? My computer slows down the same when I display the point cloud in rviz.

Qt_Yeung gravatar image Qt_Yeung  ( 2014-07-21 16:13:01 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-07-22 12:44:12 -0500

Bill Smart gravatar image

The most likely cause is that you're not using hardware accelerated video drivers. Rviz works best with nVidia graphics cards and the propriety driver. My guess is that you're using software rendering (as opposed to taking advantage of the hardware on the GPU), and that this is what's causing the slow-down. I'd suggest that you make sure you're using hardware-accelerated video drivers, and see if that helps.

The best long-term solution, though, is probably to switch to an nVidia video card.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-01 08:51:08 -0500

Seen: 786 times

Last updated: Jul 22 '14