ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Keyboard Teleop and doesn't work

asked 2014-03-28 19:44:12 -0500

fuchangjie gravatar image

updated 2016-10-24 08:36:43 -0500

ngrennan gravatar image

Hi all, I have a turtlebot 2. I roslaunch "turtlebot_bringup minimal.launch" on turtlebot and "turtlebot_teleop keyboard_teleop.launch" on my workstation after ssh into turtlebot PC. There were no errors. Afterwards I press "w" which increase only linear speed by 10%, but nothing happend. Can anyone tell me why? Thanks!

edit retag flag offensive close merge delete


do you launch both in seperate shells ssh'ed to the turtlebot? Or is the teleop on the workstation without ssh?

demmeln gravatar image demmeln  ( 2014-03-29 11:04:04 -0500 )edit

Hi Demmeln, I cannot catch you, because even without SSH, and just launch the keyboard_teleop.launch might get the right outcome, I guess. If I'm wrong, pls point it out, thanks!

Yantian_Zha gravatar image Yantian_Zha  ( 2014-03-29 14:54:21 -0500 )edit

It should work, it is just not quite clear how exactly your setup looks like. So you have two terminals, one ssh and roslauch the minimal.launch, and one without ssh with the teleop launch? Open a 3rd terminal. What does `rosnode list` output? What does `roswtf` output?

demmeln gravatar image demmeln  ( 2014-03-29 20:36:15 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2014-04-03 00:42:46 -0500

Yantian_Zha gravatar image

updated 2014-04-03 00:44:05 -0500

I guess this problem has little value to learn, because my package is installed from turtlebot officially, which might be different from you all. Problem is simple: after I rxgraph, I found problems in nodes connection, and then I check the launch file, found errors in it. I corrected it and rosmake that package again. Or maybe I did something wrong to turtlebot_teleop package previous(I think this possibility is tiny).

edit flag offensive delete link more

answered 2014-03-30 13:51:48 -0500

jihoonl gravatar image

Please make sure three things.

  1. Both computers are in the same ROS_MASTER_URI

launching keyboard teleop node without configuration would not know how to access turtlebot..

  1. ROS_HOSTNAME of both copmuters are set with their own ip address

ROS_HOSTNAME is an optional environment variable that sets the declared network address of a ROS Node or tool.

  1. Check velocity topic is connected properly.

Check rostopic list and rostopic info to make sure keyboard teleop is publishing and turtlebot is subscribing to the same topic.

edit flag offensive delete link more


You might want to set up your network properly instead of fiddling with ROS_HOSTNAME:

demmeln gravatar image demmeln  ( 2014-03-31 03:29:01 -0500 )edit

answered 2014-04-01 02:31:14 -0500

Yantian_Zha gravatar image

Hi demmeln and jihoonl, sorry for the late reply. Problem has been solved. After running rxgraph, I found problems in turtlebot_teleop package, and corrected it.

edit flag offensive delete link more


Ok good. Please mark this as being solved by accepting an answer.

demmeln gravatar image demmeln  ( 2014-04-01 02:45:22 -0500 )edit

What was the problem in turtlebot_telop package?

jihoonl gravatar image jihoonl  ( 2014-04-01 13:08:22 -0500 )edit

I also want to know the problem in turtlebot_teleop package, because my turtlebot2 works normally with a turtlebot_teleop package on Hydro.

Ken_in_JAPAN gravatar image Ken_in_JAPAN  ( 2014-04-01 20:28:59 -0500 )edit

@Ken_in_JAPAN: Where is the problem if it works?

demmeln gravatar image demmeln  ( 2014-04-02 02:20:14 -0500 )edit

After I download a package from source and compile it with catkin_make, I moved a turtlebot two weeks ago. I guess a problem of setting as jhool answers. But, Yantian_zha said to all, "I found problems in turtlebot_teleop package" so, I wanted to know the problem.

Ken_in_JAPAN gravatar image Ken_in_JAPAN  ( 2014-04-02 06:15:28 -0500 )edit

@Yantian_Zha: Thanks for the update. Please mark this as being solved by accepting an answer.

demmeln gravatar image demmeln  ( 2014-04-03 04:51:11 -0500 )edit

@Yantian_Zha: Thanks for giving us some information and the update!

Ken_in_JAPAN gravatar image Ken_in_JAPAN  ( 2014-04-03 06:54:43 -0500 )edit

You're welcome!

Yantian_Zha gravatar image Yantian_Zha  ( 2014-04-04 16:52:17 -0500 )edit

Question Tools

1 follower


Asked: 2014-03-28 19:44:12 -0500

Seen: 6,859 times

Last updated: Apr 01 '14