Ask Your Question
0

recent problem with android_apps (catkin_make)

asked 2014-03-27 12:33:20 -0600

AMiNAsFour gravatar image

I had a working environment, for developing android apps for ROS. today, I opened Android Studio, and at the start it started "refreshing the project" .. and all of the sudden I started getting errors about gradle wrapper.. I fell back to terminal, and tried to reinvoke "catkin_make" on the dir. and I got this error:

* Where:
Build file '/home/aminasfour/project/android/src/android_apps/application_management/build.gradle' line: 26

* What went wrong:
A problem occurred evaluating project ':application_management'.
> Could not create plugin of type 'LibraryPlugin'.

I've tried to download everything from scratch .. and re-followed this tutorial: http://wiki.ros.org/sig/Rosjava/Andro... . unfortunately I'm still getting the same error mentioned above. Please I need advice on how to fix it, I have a project that I need to deliver within a week. Thanks!

edit retag flag offensive close merge delete

Comments

I suspect this is due to a recent change on your system. You could try reviewing the package install logs in /var/log/dpkg if you're on Ubuntu

ahendrix gravatar imageahendrix ( 2014-03-27 12:51:51 -0600 )edit

It's not, the latest update that appears there, dates back to two weeks ago (and it used to work then)

AMiNAsFour gravatar imageAMiNAsFour ( 2014-03-27 13:01:37 -0600 )edit

Try to update the distributionUrl=http\://services.gradle.org/distributions/gradle-1.10-all.zip in the gradle/wrapper/gradle-wrapper.properties. This solved my problems regarding the same issue.

fapofa gravatar imagefapofa ( 2014-04-09 04:23:15 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-04-09 14:58:45 -0600

Daniel Stonier gravatar image

If I recall correctly, I got the same error with the recent android studio/build tools version/gradle android plugin and gradle updates. Some of these are embedded in rosjava_build_tools (sdk version and android gradle plugin), so if you updated rosjava_build_tools on hydro, then it will automatically be trying to use 19.0.3 build tools version and android gradle plugin 0.9.+.

If you want to keep to old unsupported (by android studio) versions, then simply override these variables/dependencies in your local build.gradle files. Otherwise update your android studio/rosjava_build_tools and it should disappear.

For the record, I'm now using (April '14)

  • Android 0.5.4
  • Build Tools 19.0.3
  • Android Gradle Plugin 0.9+
  • Gradle 1.11
edit flag offensive delete link more
1

answered 2014-04-12 07:38:04 -0600

davidnunez gravatar image

See this commit which seems to fix this issue:

https://github.com/rosjava/android_ap...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-27 12:33:20 -0600

Seen: 1,029 times

Last updated: Apr 12 '14