Error on Installing CCNY Package on Hydro

asked 2014-03-27 07:42:46 -0500

pinocchio gravatar image

updated 2014-03-27 10:19:37 -0500

Hi guys, I am trying to run CCNY Package for kinect on hydro for mapping following , although the wiki is for groovy.

First I create a rosbuild workspace and a directory to download the package in it . After installing dependencies, I run rosmake ccny_rgbd_tools. It shows Built 71 packages with 0 failures., but several files are missing. Then I run roslaunch ccny_openni_launch openni.launch. It says that it is initiating. However, when I run roslaunch ccny_rgbd vo+mapping.launch, the program shuts down. The results of these commands are listed below (Please click on "more" for detail). Could someone tell me how to install the package on hydro? Many thanks.

Result of rosmake

rical@rical-CF-19RHRAX1M:~/rosbuild_workspace$ rosmake ccny_rgbd_tools [ rosmake ] rosmake starting...
[ rosmake ] Packages requested are: ['ccny_rgbd_tools']
[ rosmake ] Logging to directory /home/rical/.ros/rosmake/rosmake_output-20140327-131452 [ rosmake ] Expanded args ['ccny_rgbd_tools'] to: ['lib_rgbdtools', 'ccny_rgbd_data', 'ccny_rgbd', 'ccny_openni_launch'] [rosmake-0] Starting >>> ccny_rgbd_data [ make ]
[rosmake-0] Finished <<< ccny_rgbd_data ROS_NOBUILD in package ccny_rgbd_data No Makefile in package ccny_rgbd_data [rosmake-0] Starting >>> lib_rgbdtools [ make ]
[rosmake-1] Starting >>> catkin [ make ]
[rosmake-1] Finished <<< catkin ROS_NOBUILD in package catkin No Makefile in package catkin [rosmake-2] Starting >>> ccny_openni_launch [ make ]
[rosmake-2] Finished <<< ccny_openni_launch ROS_NOBUILD in package ccny_openni_launch [rosmake-2] Starting >>> genmsg [ make ]
[rosmake-1] Starting >>> console_bridge [ make ]
[rosmake-3] Starting >>> rospack [ make ]
[rosmake-1] Finished <<< console_bridge ROS_NOBUILD in package console_bridge No Makefile in package console_bridge [rosmake-2] Finished <<< genmsg ROS_NOBUILD in package genmsg No Makefile in package genmsg [rosmake-1] Starting >>> cpp_common [ make ]
[rosmake-2] Starting >>> genlisp [ make ]
[rosmake-3] Finished <<< rospack ROS_NOBUILD in package rospack No Makefile in package rospack [rosmake-3] Starting >>> genpy [ make ]
[rosmake-1] Finished <<< cpp_common ROS_NOBUILD in package cpp_common No Makefile in package cpp_common [rosmake-1] Starting >>> gencpp [ make ]
[rosmake-2] Finished <<< genlisp ROS_NOBUILD in package genlisp No Makefile in package genlisp [rosmake-2] Starting >>> rostime [ make ]
[rosmake-1] Finished <<< gencpp ROS_NOBUILD in package gencpp No Makefile in package gencpp [rosmake-1] Starting >>> roslib [ make ]
[rosmake-2] Finished <<< rostime ROS_NOBUILD in package rostime No Makefile in package rostime [rosmake-3] Finished <<< genpy ROS_NOBUILD in package genpy No Makefile in package genpy [rosmake-3] Starting >>> message_generation [ make ]
[rosmake-2] Starting >>> roscpp_traits [ make ]
[rosmake-1] Finished <<< roslib ROS_NOBUILD in package roslib No Makefile in package roslib [rosmake-1] Starting >>> rosunit [ make ]
[rosmake-3] Finished <<< message_generation ROS_NOBUILD in package message_generation No Makefile in package message_generation [rosmake-3] Starting >>> roslang [ make ]
[rosmake-3] Finished <<< roslang ROS_NOBUILD in package roslang No Makefile in package roslang [rosmake-2] Finished <<< roscpp_traits ROS_NOBUILD in package roscpp_traits No Makefile in package roscpp_traits [rosmake-3] Starting >>> xmlrpcpp [ make ]
[rosmake-2] Starting >>> roscpp_serialization [ make ]
[rosmake-1] Finished <<< rosunit ROS_NOBUILD in package rosunit No Makefile in package rosunit [rosmake-2] Finished <<< roscpp_serialization ROS_NOBUILD in package roscpp_serialization No Makefile in package roscpp_serialization [rosmake-3] Finished <<< xmlrpcpp ROS_NOBUILD in package xmlrpcpp No Makefile in package xmlrpcpp [rosmake-2] Starting >>> message_runtime [ make ]
[rosmake-3] Starting >>> rosgraph [ make ]
[rosmake-1] Starting >>> rosclean [ make ]
[rosmake-2] Finished <<< message_runtime ROS_NOBUILD in package message_runtime No Makefile in package message_runtime [rosmake-1] Finished <<< rosclean ROS_NOBUILD in package rosclean No Makefile in package rosclean [rosmake-1] Starting >>> rosbag_storage [ make ]
[rosmake-3] Finished <<< rosgraph ROS_NOBUILD in package rosgraph No Makefile in package rosgraph [rosmake-3] Starting >>> rosbuild [ make ]
[rosmake-2] Starting >>> std_msgs ...


edit retag flag offensive close merge delete


it seems to be installed right. why do you think any thing is missing? what happens if you just start "roslaunch ccny_openni_launch openni.launch publish_cloud:=true"? can you see rgb and depth image in rviz?

RodBelaFarin gravatar image RodBelaFarin  ( 2014-03-27 08:48:17 -0500 )edit

Hi @RodBelaFarin thanks for you help. I say something is missing because it says "no file in ***" after rosmake. The detailed results of each step are listed in question (please click "more"). I would like to know if I need to change some code to apply this package on hydro? Also, is rosbuild ws OK?

pinocchio gravatar image pinocchio  ( 2014-03-27 09:45:19 -0500 )edit

ok, pls double check your ROS_PACKAGE_PATH if there are no makefiles found! rosbuild is OK, catkin would work also. just follow the installation steps from groovy step by step. For me this worked in Hydro without any changes.

RodBelaFarin gravatar image RodBelaFarin  ( 2014-03-27 22:15:39 -0500 )edit

Hi @RodBelaFarin thank you so much. I add ROS_PACKAGE_PATH, but error exists. Could you please show me the result of running "roslaunch ccny_openni_launch openni.launch publish_cloud:=true" on your system? Many thanks.

pinocchio gravatar image pinocchio  ( 2014-03-28 05:11:33 -0500 )edit

sorry. atm i do not work any more on a pc with ROS.

RodBelaFarin gravatar image RodBelaFarin  ( 2014-03-30 08:07:37 -0500 )edit