Ask Your Question
0

[catkin_make] Cmake Error

asked 2014-03-10 07:50:46 -0500

runout gravatar image

updated 2016-10-24 09:02:10 -0500

ngrennan gravatar image

Hi everyone. I'm doing this thing (youbot ros-hydro-wrapper-for-kuka-youbot) trying to make youbot by Kuka working and there's an error on the last "$ catkin_make".

$ cd ~/catkin_ws/src
$ git clone github.com /youbot/youbot_driver_ros_interface.git -b hydro-devel
$ cd ..
$ catkin_make
$ sudo setcap cap_net_raw+ep devel/lib/youbot_driver_ros_interface/youbot_driver_ros_interface

it's my first time with Ubuntu and ROS, so I don't really know what gone wrong.

CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:72 (find_package): Could not find a package configuration file provided by "brics_actuator" with any of the following names:

brics_actuatorConfig.cmake
brics_actuator-config.cmake

Add the installation prefix of "brics_actuator" to CMAKE_PREFIX_PATH or set "brics_actuator_DIR" to a directory containing one of the above files. If "brics_actuator" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first):
youbot_driver_ros_interface/CMakeLists.txt:5 (find_package)

-- Configuring incomplete, errors occurred! make: * [cmake_check_build_system] Error 1 Invoking "make cmake_check_build_system" failed

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-03-10 11:20:06 -0500

tfoote gravatar image

It looks like the youbot driver requires the brics_actuator package but you have not installed it on your system or put it in your workspace. You'll need to resolve that dependency before you can build that package.

edit flag offensive delete link more

Comments

Thanks, well the next question will be: how to do that. I've found brics_actuator git, but I really new at linux so I have no idea what to do with that. :(

runout gravatar imagerunout ( 2014-03-29 02:55:23 -0500 )edit

found it. That's what I was needed. brics_actuator. [$ sudo apt-get install ros-hydro-brics-actuator] pr2_msgs. [$ sudo apt-get install ros-hydro-pr2-msgs] Now I got new problem with: [youbot_driver.launch] is neither a launch file in package [youbot_driver_ros_interface] nor is [youbot_driver_ros_interface] a launch file name But I guess that's another question.

runout gravatar imagerunout ( 2014-03-29 04:16:42 -0500 )edit

$ sudo apt-get install ros-hydro-youbot-driver-ros-interface I edited the youbot-ethercat config file from eth0 to eth1 (path is /opt/ros/hydro/share/youbot_driver/config, you'll need sudo access to edit it). But I am getting an error [ERROR] [1400149466.933178411]: No EtherCAT connection: [FATAL] [1400149466.933450442]: No socket connection on eth1 Excecute as root (I have the manipulator at eth1 only.) Help please?

ratneshmadaan gravatar imageratneshmadaan ( 2014-05-15 00:26:00 -0500 )edit
0

answered 2014-05-15 00:30:24 -0500

In addition to the above answer, it'll be best if you install these packages:

ros-hydro-youbot-description
ros-hydro-youbot-driver
ros-hydro-youbot-driver-ros-interface ros-hydro-youbot-gazebo-robot ros-hydro-youbot-gazebo-worlds ros-hydro-youbot-simulation ros-hydro-youbot-gazebo-control

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-10 07:50:46 -0500

Seen: 3,138 times

Last updated: May 15 '14