Ask Your Question
0

How to install object_manipulation package for ros hydro on ubuntu 13.10

asked 2014-03-06 19:19:45 -0500

Alice gravatar image

I am trying to install object_manipulation package for ros hydro (which I installed from source) on ubuntu 13.10. To do that I downloaded the source of package from github link and tried to run following command in the downloaded folder:

sudo /opt/ros/hydro/bin/catkin_make_isolated --install --install-space /opt/ros/hydro

However I am getting following error: Traceback (most recent call last): File "/opt/ros/hydro/bin/catkin_make_isolated", line 12, in <module> from catkin.builder import build_workspace_isolated ImportError: No module named catkin.builder

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-03-09 21:52:54 -0500

Alice gravatar image

updated 2014-03-09 23:11:12 -0500

I did source the bash file before running catkin_make_isolated.

Update: I realized when I use sudo, previous source command does not have any effect. Therefore I switched to root. Issued the source command and then used catkin_make_isolated --install --install-space /opt/ros/hydro . But now I am getting following error: Could not find source space : None

I get the same error when I install it as a non root user without using sudo by changing the path to a local path in home folder.

edit flag offensive delete link more
0

answered 2014-03-07 04:38:10 -0500

Dirk Thomas gravatar image

You need to source /opt/ros/hydro/setup.bash before running catkin_make_isolated else the necessary Python modules are not on the PYTHONPATH.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-06 19:19:45 -0500

Seen: 252 times

Last updated: Mar 09 '14