Turtlebot outputting over serial, but not receiving

asked 2014-03-06 16:41:22 -0500

nckswt gravatar image

updated 2014-03-06 17:01:08 -0500

I have a charging Turtlebot that seems to half-work. When I run roslaunch turtlebot_bringup minimal.launch, I get the Failed to open on port /dev/ttyUSB0 error that so many others have gotten. However, I also am able to open a serial connection in minicom, and I get data from the Turtlebot that seems to be battery charge information.

How is it that I have a working serial connection, but I can't seem to send commands at all? I've done all the regular chmodding and fixes to udev rules, but I'm at a loss a this point!

Using ROS hydro, if that helps.

EDIT - added the following info:

$ ls -la /dev/ttyUSB*
> crw-rw-rw- 1 root dialout 188, 0 Mar 6 21:23 /dev/ttyUSB0
$ lsusb
> ...blahblah...
> idVendor 0x0403 FTDI ltd.
> idProduct 0x6015
$ cat /etc/udev/rules.d/52-turtlebot.rules
> ATTRS{idProduct}=="6015",ATTRS{idVendor}=="0403",MODE="666",GROUP="dialout"
edit retag flag offensive close merge delete


Are you (and/or the user running the `minimal.launch`) in the dialout group?

William gravatar image William  ( 2014-03-07 04:01:08 -0500 )edit

Yup! Any other ideas? I'm pretty stumped =/

nckswt gravatar image nckswt  ( 2014-03-07 14:20:23 -0500 )edit

I have no idea, where did you get the turtlebot from? Perhaps call the distributor, it may be a hardware problem, is it a Kabuki (Turtlebot2) or a iRobot Create base (Turtlebot1)?

William gravatar image William  ( 2014-03-09 08:50:12 -0500 )edit

It's a iRobot Create base. We have a few of them, and none of them have worked (tried different cables, different robots, different laptops - nothing!)

nckswt gravatar image nckswt  ( 2014-03-10 06:38:18 -0500 )edit

Are you possibly running the node for the Kabuki base instead of the ones for the iRobot create?

William gravatar image William  ( 2014-03-10 07:01:11 -0500 )edit

I checked into that, and nope - it's the iRobot create node. I'm also trying to simply connect and send commands via minicom/screen, and it doesn't look like any data is ever sent to the iRobot when I just connect manually (though I'm still getting the battery information sent to my computer!)

nckswt gravatar image nckswt  ( 2014-03-10 07:11:13 -0500 )edit

Strange, this is beyond my expertise to fix, it maybe that the cable you are using is not providing bidirectional communication. Maybe someone from the Turtlebot community could give some more insight...

William gravatar image William  ( 2014-03-10 07:44:37 -0500 )edit

I've made progress! I tried opening up a serial link in python and it worked – it seems like there might be an issue with minimal.launch, then. I'll look into it! Thanks for all your help, william!

nckswt gravatar image nckswt  ( 2014-03-10 10:22:35 -0500 )edit