Ask Your Question
2

How versioned build_depend works?

asked 2014-03-06 07:20:30 -0500

130s gravatar image

updated 2014-03-06 08:00:33 -0500

Inspired by this thread, I'm trying to utilize version_gte defined in REP-0127. I created an empty package beginner_tutorials from a tutorial, then placed in package.xml:

  <build_depend version_gte="1.10.3" version_lt="2.0">roscpp</build_depend>

where $ rosversion roscpp returns 1.10.2, expecting build would fail. But catkin_make-ing (tried install too) doesn't not even yield warning and just passed normally. Am I missing something?


Update) Answer from @Dirk Thomas gong something in me, and it was actually the following that was missing.

catkin_package(
  CATKIN_DEPENDS roscpp
)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-03-06 07:39:11 -0500

Dirk Thomas gravatar image

The CMake configure step does show a warning if you find_package() your build dependency and it does not satisfy the version specified in your package.xml file.

edit flag offensive delete link more

Comments

Is there a way to let catkin return error instead of warning when the specified version dependency is not met?

130s gravatar image 130s  ( 2014-05-13 15:51:19 -0500 )edit
1

No, currently these are always only warnings. Since sometimes this is a scenario a developer might have setup locally it would be bad to escalate it into an error.

Dirk Thomas gravatar image Dirk Thomas  ( 2014-05-14 14:35:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-06 07:20:30 -0500

Seen: 259 times

Last updated: Mar 06 '14