Ask Your Question
0

ROS Listener (Android)

asked 2014-02-23 19:41:02 -0500

Jordan Markov gravatar image

Hello,
I have set up a navigation stack on my PC and now I'm trying to run a slightly modified copy of android_teleop. Everything seems to work, but the android app does not receive any messages, although I can see them in rviz on the PC and I can see that the android node is connected to the correct topic using rqt_graph. The published topic (/virtual_joystick/cmd_vel) is working.

edit retag flag offensive close merge delete

Comments

It's not the missing ROS_IP/ROS_HOSTNAME problem?

Daniel Stonier gravatar imageDaniel Stonier ( 2014-02-26 19:25:40 -0500 )edit

It's not that, because the application connects to the master and successfully sends messages to the cmd_vel topic. Also it looks like it is subscribed to the other topics, but it doesn't receive the messages, just like if they are not published. Is there a firewall on the android phone I need to disable?

Jordan Markov gravatar imageJordan Markov ( 2014-02-26 20:21:16 -0500 )edit

Not that I know of, but I haven't done alot of testing on different devices to be sure. Do recheck the ROS_IP settings though, if I remember correctly, publishing can be ok, but subscribing will fail.

Daniel Stonier gravatar imageDaniel Stonier ( 2014-02-27 18:01:01 -0500 )edit

Sounds like a one-way route. Have you tested pinging from master to subscriber and vice versa? It mostly is a "route add -net 10.20.30.0 netmask 255.255.255.0 gateway 10.20.30.1" problem.

CalisM gravatar imageCalisM ( 2014-12-28 11:15:37 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-12-26 12:13:52 -0500

Anis gravatar image

I am having the same problem! Did you find a solution. When I run the Teleop Hyrdo downloaded from Playstore ,it works fine with no problem. However, when I upload the android_tutorial_teleop to my android device, the robot is unresponsive. When I make rostopic info on the cmd_vel topic, I found the following

rostopic info virtual_joystick/cmd_vel Type: geometry_msgs/Twist Publishers: * /android/virtual_joystick ( http://192.168.1.2:46089/ ) Subscribers: None

There is no subsriber. However, when I run the Telop Hydro downloaded from PlayStore, it shows the following

rostopic info /turtlebot/application/android/virtual_joystick/cmd_vel Type: geometry_msgs/Twist Publishers: * /android/virtual_joystick ( http://192.168.1.2:37236/ ) Subscribers: * /mobile_base_nodelet_manager_turtlebot01_3181_5535754284978469755 ( http://192.168.1.9:52341/ )

The turtlebot is subscribed and responds to the command.

I really could find what is the issue with the code of the Tutorial found in android_core (hydro).

I hope to receive some help on this

A

edit flag offensive delete link more

Comments

Hi, I gave up with this problem a couple of months ago. After my research I suspect that the Android version I'm using is not working. I managed to run the teleop app on an emulator with older version of Android, Honeycomb as long as I remember. Anyway, your problem seems different than mine.

Jordan Markov gravatar imageJordan Markov ( 2015-01-05 03:35:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-02-23 19:41:02 -0500

Seen: 854 times

Last updated: Dec 26 '14