Ask Your Question
0

Problems with openni_tracker launching

asked 2014-02-18 22:02:00 -0500

Latif Anjum gravatar image

Hi,

I am trying to use openni_tracker. I have ros-fuerte-openni* installed. roslaunch openni_launch openni.launch is working properly and I can see the image in rviz. However, when I run rosrun openni_tracker openni_tracker, initially there was the following error.

Find user generator failed: This operation is invalid!

I googled for the solution to this problem and was instructed to install NITE-bin-dev-linux-64-v1.5.2.23. Now the error has change to the following.

Find user generator failed: Can't create any node of the requested type!

Any help?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-19 03:54:22 -0500

I see you posted new answers here and here. Just FYI, that's really not how this site should work; the answers are really for answers, not new questions.

Based on all of your information I have several pieces of advice. First, I already mentioned you should update NITE on one of your comments. After seeing this question, I see you already did that. On Fuerte and 12.04, I just tried openni_tracker with NITE versions 1.5.2.23 and 1.5.2.21 and it worked with both. During my testing I noticed that if I run openni_tracker before starting up the Kinect/Asus with openni_launch, I get the same error you are seeing. So first hint, make sure the device is running and publishing point clouds before starting the tracker.

Second hint: based on the second comment I linked above, you are getting a bunch of ELFCLASS warnings in the output of niReg -l. This sounds to me like you installed the x64 version of NITE, but you are on an x86 system. Try installing NITE-Bin-Dev-Linux-x86-v1.5.2.23 instead.

edit flag offensive delete link more

Comments

Thank you sir. Your suggestion to install NITE for x86 worked. Sorry for posting on multiple questions, will be careful in future.

Latif Anjum gravatar image Latif Anjum  ( 2014-02-19 21:51:48 -0500 )edit
2

@jarvisschultz Please tell me a solution for this error InitFromXml failed: Can't create any node of the requested type! I get this if I run openni_tracker .

gaussian gravatar image gaussian  ( 2015-01-07 11:06:54 -0500 )edit

i was getting same error, InitFromXml failed: Can't create any node of the requested type! any clue how to resolve this please

anilmullapudi gravatar image anilmullapudi  ( 2016-07-18 10:37:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-02-18 22:02:00 -0500

Seen: 1,899 times

Last updated: Feb 19 '14