Ask Your Question
0

Arduino Galileo: compile error when using ros

asked 2014-02-17 02:05:41 -0600

Moritz Maus gravatar image

updated 2014-02-17 02:13:45 -0600

I've installed the Arduino IDE 1.5.3 for a Galileo-Board. Following the instructions on the wiki, I installed rosserial from github, and "catkin_make"ed and "catkin_make install"ed my ws. Everything worked fine.

When I came to run "rosrun rosserial_arduino make_libraries.py .", it stops with an error:

*** Warning, failed to generate libraries for the following packages: ***
    map_msgs

According to several posts and viewing the source of make_libraries.py, this should not be too bad, because generating the messages is the last thing done (correct?). Still, I'd be glad if someone knows how to fix this.

My actual problem is when I compile any of the ROS examples, I get something like

Arduino: 1.5.3 (Linux), Board: "Intel® Galileo"

done
xyz.cpp.o: In function `ArduinoHardware::init()':
/home/moritz/Arduino/libraries/ros_lib/ArduinoHardware.h:96: undefined reference to `HardwareSerial::begin(unsigned long)'
collect2: error: ld returned 1 exit status

To me this looks like a linker error(?), but that does not help me any further. Compiling simple examples and uploading them to the board works fine.

Any help would be appreciated!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2014-04-08 19:28:36 -0600

Moritz Maus gravatar image

No, I came to the conclusion that the Galileo-System does not operate well with ROS (at least currently), so we will potentially switch to another (Arduino?) platform.

I checked the general (non-Galileo) IDE - it does not seem to have any problem with ROS, that is, I can compile the ROS examples. However it does not support the Galileo-board :(

edit flag offensive delete link more
0

answered 2014-04-08 17:08:49 -0600

dhu_student gravatar image

I faced the same problem when I compiled "hello world" of ROS examples. Have you solved it? Thanks for any help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-02-17 02:05:41 -0600

Seen: 340 times

Last updated: Apr 08 '14