Ask Your Question
0

Turtlebot Upstart Install Failure

asked 2012-02-08 01:43:53 -0500

osuairt gravatar image

updated 2012-02-21 03:02:33 -0500

The upstart seems to be touch and go, I have had it working previously on another netbook, didn't do anything special just followed the instructions from

http://www.ros.org/wiki/turtlebot_bringup/Tutorials/TurtleBot%20Bringup

turtlebot@maia:/opt/ros/electric/stacks/turtlebot/turtlebot_bringup/upstart$ sudo ./install.bash wlan0
Installing using network interface wlan0.

So, no complaints so far. I reboot the netbook for good luck. When it was started back up, then I tried to stop the service in case it started on startup, which was the case when I had it running on another netbook. However, when I stopped it, I got the following error.

turtlebot@maia:~$ sudo service turtlebot stop
[sudo] password for turtlebot: 
stop: Unknown instance:

So, then I went ahead and tried to start the service.

turtlebot@maia:~$ sudo service turtlebot start
turtlebot start/running, process 1734

Looking good. However, the master doesn't seem to be working.

turtlebot@maia:~$ rosnode list
ERROR: Unable to communicate with master!

This is the first part of my problem with the upstart, however, I cannot give you an example of it not starting a proper configuration because it won't start the master. So, first things first, what could be in the way of starting the master?

With the above previously ironed out below, I'll get to the main point of my question. I can restart the turtlebot, I can double check that the turtlebot service is running, however after this if I go ahead try and do a simple teleop, it will not move. If however, I stop the turtlebot service and run the minimal.launch, everything works fine. So I checked the topics running with startup.

image description

I then stop the turtlebot service and do minimal.launch.

image description

It is clear to see that the following are missing with the startup.

/cmd_vel

/turtlebot_node/sensor_state

There haven't been changes made to the config files, so I am wondering why doesn't this work as soon as I download it from the repos? What am I missing?

edit retag flag offensive close merge delete

Comments

to debug what's going on can you post the output of `ps auxf`?
tfoote gravatar image tfoote  ( 2012-02-09 08:55:59 -0500 )edit

I've gone ahead and updated this question to outline what I was really asking about.

osuairt gravatar image osuairt  ( 2012-02-21 03:57:35 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2012-02-09 23:50:21 -0500

osuairt gravatar image

updated 2012-02-09 23:54:32 -0500

There was a bit of a delay, now I have installed again. So, it was that I was missing daemontools before, that is no problem. When restarting the netbook, upstart starts. If I stop the service, then start again, I do not get the beep from the Turtlebot as demonstrated in the upstart video by Melonee. If I then run minimal, I do get the beep. The following are the nodes that are currently running when I start upstart by itself.

http://imgur.com/DAIoN

edit flag offensive delete link more

Comments

unfortunately the darn create doesn't always beep. it's somewhat frustrating.. If the turtlebot_node is up and spitting out data then things are running. In the next release, coming soon, there will be a notice in the dashboard to show if the turtlebot_node is running.
mmwise gravatar image mmwise  ( 2012-02-10 10:07:30 -0500 )edit

I've gone ahead and updated this question to outline what I was really asking about.

osuairt gravatar image osuairt  ( 2012-02-21 03:57:49 -0500 )edit

We've added daemontools as a dependency, so this shouldn't be a problem in the future.

fergs gravatar image fergs  ( 2012-02-21 21:46:41 -0500 )edit

Great thanks.

osuairt gravatar image osuairt  ( 2012-02-27 04:13:50 -0500 )edit

I am having a similar problem. http://answers.ros.org/question/33198/stop-unknown-instance But installing daemon tools didn't solve mine. Did you do something else to fix this?

Ozkan gravatar image Ozkan  ( 2012-05-03 04:54:57 -0500 )edit
0

answered 2012-02-08 06:53:26 -0500

osuairt gravatar image

I've a bit of a delay till I can get back to the machine. I do think however, I am getting the above because I have not installed daemon-tools. I will get back to it tomorrow, and let you know if that was the case.

edit flag offensive delete link more
0

answered 2012-02-08 03:35:49 -0500

fergs gravatar image

Is wlan0 actually the name of your interface? What does the output of 'ifconfig' look like?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-02-08 01:43:53 -0500

Seen: 1,249 times

Last updated: Feb 21 '12