Ask Your Question
1

roscore error

asked 2012-02-05 19:47:40 -0600

faizi gravatar image

updated 2017-08-15 21:31:30 -0600

130s gravatar image

when I run roscore command i face the following error.I tried alot to get solve but in vain.Any one who know please help.how to solve this

logging to /home/faiz/.ros/log/fc2de17e-50a6-11e1-93e0-0024811c47cc/roslaunch-faiz-4674.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Unable to contact my own server at [http://faiz:48024/].
This usually means that the network is not configured properly.

A common cause is that the machine cannot ping itself.  Please check
for errors by running:

    ping faiz

For more tips, please see

    http://www.ros.org/wiki/ROS/NetworkSetup
edit retag flag offensive close merge delete

Comments

Can you please give more information? Can you ping faiz? Did you go through the network setup steps? Did you try setting ROS_IP?
Lorenz gravatar imageLorenz ( 2012-02-05 22:00:59 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-02-05 22:41:21 -0600

Can you ping your own computer? If you execute:

ping faiz

Does the ping come pack? You could consider setting your ROS_IP or ROS_HOSTNAME variables. For example add:

export ROS_IP="xxx.xxx.xxx.xxx"

to your .bashrc, where the xs are your IP number. If you don't know where to find your IP, use ifconfig.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-05 19:47:40 -0600

Seen: 5,515 times

Last updated: Aug 15 '17