Ask Your Question
0

audio_play on turtlebot: messages being sent, but no audio output

asked 2012-01-26 08:33:29 -0600

brianpen gravatar image

updated 2012-01-26 08:35:36 -0600

Hello,

I'm trying to get audio streaming back from my turtlebot and was delighted to find the audio_common package which provides audio_play and audio_capture. Sadly, it doesn't seem to be working.

I'm following the tutorial found here: http://www.ros.org/wiki/audio_common/Tutorials/Streaming%20audio

Setup

  • On my turtlebot, I installed sound_common with "apt-get install ros-electric-sound-drivers"
  • My microphone and speakers are configured correctly, I'm able to record and play back sounds.
  • The command to test my audio setup works. It echos sounds from the microphone.
gst-launch-0.10 alsasrc ! audioconvert ! audioresample ! alsasink
  • I launched both audio_capture and audio_play as per the tutorial
$ roslaunch audio_capture capture.launch
$ roslaunch audio_play play.launch

Problem and Troubleshooting

  • No sound output.
  • Both scripts launched without error.
  • I've verified that the nodes are connected using rxgraph
  • "rostopic echo audio" streams audio messages.
  • I can see the microphone input level bouncing, but the output level is doing nothing.
  • I've used sound_play to verify that I can play sounds and my volume settings are correct.

From what I can tell, everything should be working. But I still get no output. Any ideas on how to troubleshoot this?

Thanks,

-Brian

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-01-26 13:12:42 -0600

Ryan gravatar image

Have you tried the example in the turtlebot_sounds package?

edit flag offensive delete link more

Comments

Yes, it works correctly and plays the sounds.
brianpen gravatar imagebrianpen ( 2012-01-27 03:40:28 -0600 )edit
Your problem is likely that audo_play cannot process the audio you have chosen due to a codec issue.
tfoote gravatar imagetfoote ( 2012-01-28 06:27:39 -0600 )edit
1
hmm... thanks for the suggestion, I'll look at that. any suggestions for troubleshooting codec issues?
brianpen gravatar imagebrianpen ( 2012-01-31 05:48:42 -0600 )edit
1

Have you been able to solve this problem? I am having the same kind of issues at the moment using audio_play. However, in the beginning I have sound playback, but it stops after a little while.

mathijsdelangen gravatar imagemathijsdelangen ( 2014-02-24 01:17:42 -0600 )edit
0

answered 2012-01-26 10:39:13 -0600

joq gravatar image

The sound on this computer may be muted. Try playing a sound file directly.

edit flag offensive delete link more

Comments

I've tried other files and gstreamer (see the troubleshooting section of the post), and they all work correctly. That's what's so strange about it, I've troubleshot most of the pieces independently and it should be working. As far as I can tell, the problem is in audio_play, but I'm not sure how to troubleshoot it.
brianpen gravatar imagebrianpen ( 2012-01-27 03:37:57 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-26 08:33:29 -0600

Seen: 1,944 times

Last updated: Jan 26 '12