Ask Your Question
1

problem in transform from map to base

asked 2012-01-25 01:28:10 -0500

Alireza gravatar image

updated 2012-01-25 01:28:51 -0500

Hi, when i am setting up a navigation stack for my pioneer robot but when i am running move_base.launch after receiving a static map from map_server its writing below warning: "Waiting on transform from /base_footprint to /map to become available before running costmap , tf error."

currently my tf_tree is something like this:

odom_combined---> base_footprint ----> base_laser

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2012-01-25 01:30:37 -0500

Lorenz gravatar image

Do you have amcl or gmapping running? When using a static map published by the map server, you need to run amcl. It will localize your robot in the map and publish the transform from map to odom_combined.

edit flag offensive delete link more
2

answered 2012-01-25 01:43:26 -0500

Alireza gravatar image

AMCL will run with move_base.launch !

edit flag offensive delete link more

Comments

If you checked that amcl is running (e.g. with rosnode list) it doesn't get the data it requires, i.e. either the odom topic or laser scans are not coming in. Please don't answer in a new question but either edit your question or post a comment. This is not a forum.
Lorenz gravatar imageLorenz ( 2012-01-25 01:52:25 -0500 )edit
Ok,Thanks, Sorry about that , i'm new to Ros community !
Alireza gravatar imageAlireza ( 2012-01-25 01:59:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-25 01:28:10 -0500

Seen: 2,371 times

Last updated: Jan 25 '12