Ask Your Question
1

Problem with rviz

asked 2014-02-04 03:15:07 -0600

hamid gravatar image

HI I don't know what happened I ran rviz very well but after 2 hours I can't run rviz

when I type "rosrun rviz rviz" , I got this error :

> /opt/ros/hydro/lib/rviz/rviz: symbol > lookup error: > /opt/ros/hydro/lib/librviz.so: > undefined symbol: > _ZN3ros7console5printEPNS0_10FilterBaseEPvNS0_6levels5LevelEPKciS7_S7_z

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-04 06:50:59 -0600

Dereck gravatar image

have you tried to update your system recently? Try this again:

sudo apt-get update
sudo apt-get upgrade
edit flag offensive delete link more

Comments

1

This should work. There was a problem with `rosconsole` and ABI compliance at one point.

William gravatar imageWilliam ( 2014-02-04 06:54:56 -0600 )edit

I use "sudo apt-get -f install" then my rviz run properly.But I don't know what's happen after this command.

hamid gravatar imagehamid ( 2014-02-04 19:21:38 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-02-04 03:15:07 -0600

Seen: 289 times

Last updated: Feb 04 '14