Ask Your Question
0

Package pcl - Ubuntu 13.10 - Installation ROS Groovy from source

asked 2014-01-31 12:57:32 -0500

bapclenet gravatar image

updated 2016-10-24 09:02:17 -0500

ngrennan gravatar image

Hello,

I'm trying to install Ros Groovy on Ubuntu 13.10. (Yes Groovy because the last project I used uses it) I'm following this tutorial: wiki.ros.org/groovy/Installation/Source

But I'm stuck when I try to run this command:

./src/catkin/bin/catkin_make_isolated --install-space /opt/ROS/groovy/

make[2]: *** [common/CMakeFiles/pcl_common.dir/src/common.cpp.o] Error 1
make[2]: ***
[common/CMakeFiles/pcl_common.dir/src/distances.cpp.o]
Error 1 make[2]: ***
[common/CMakeFiles/pcl_common.dir/src/io.cpp.o]
Error 1 make[2]: ***
[common/CMakeFiles/pcl_common.dir/src/intersections.cpp.o]
Error 1 make[1]: ***
[common/CMakeFiles/pcl_common.dir/all]
Error 2 make[1]: *** Waiting for
unfinished jobs.... make[2]: ***
[octree/CMakeFiles/pcl_octree.dir/src/octree_impl.cpp.o]
Error 1 make[1]: ***
[octree/CMakeFiles/pcl_octree.dir/all]
Error 2 

Linking CXX shared library
../lib/libpcl_io_ply.so 

[  4%] Built
target pcl_io_ply

make: *** [all]
Error 2

<== Failed to process package 'pcl':

Command
'/opt/ROS/ros_catkin_ws/devel_isolated/nodelet_topic_tools/env.sh
make -j8 -l8' returned non-zero exit
status 2

Reproduce this error by running:

==> cd /opt/ROS/ros_catkin_ws/build_isolated/pcl
&&
/opt/ROS/ros_catkin_ws/devel_isolated/nodelet_topic_tools/env.sh
make -j8 -l8

Command failed, exiting.

I have already checked the pcl_find_ros.cmake and it's seems up to date. (h ttps://github.com/ros-gbp/pcl-release/commits/bf43ffc0eebca4042c6765319c4dd211409d7ace/cmake/pcl_find_ros.cmake) Any ideas? :\

EDIT: Command:

./src/catkin/bin/catkin_make_isolated -j1 --install-space /opt/ROS/groovy/

make[2]: *** [common/CMakeFiles/pcl_common.dir/src/pcl_base.cpp.o] Error 1
make[1]: *** [common/CMakeFiles/pcl_common.dir/all] Error 2
make: *** [all] Error 2
<== Failed to process package 'pcl': 
  Command '/opt/ROS/ros_catkin_ws/devel_isolated/nodelet_topic_tools/env.sh make -j1' returned non-zero exit status 2

Reproduce this error by running:
==> cd /opt/ROS/ros_catkin_ws/build_isolated/pcl && /opt/ROS/ros_catkin_ws/devel_isolated/nodelet_topic_tools/env.sh make -j1

Command failed, exiting.
edit retag flag offensive close merge delete

Comments

I feel like the actual error message is missing here. Do you get any more information by running ./src/catkin/bin/catkin_make_isolated -j1 --install-space /opt/ros/groovy/ ?

ahendrix gravatar image ahendrix  ( 2014-01-31 18:14:02 -0500 )edit

I edited my post, it's not exactly the same error but quite similar. What do you think?

bapclenet gravatar image bapclenet  ( 2014-02-01 02:18:52 -0500 )edit

Can you include more of the error output? I don't see anything that actually looks like an error from the compiler. Ideally, everything from the first error message onward is useful.

ahendrix gravatar image ahendrix  ( 2014-02-01 10:13:22 -0500 )edit

Does "VERBOSE=1 ./src/catkin/bin/catkin_make_isolated -j1 --install-space /opt/ros/groovy/" output more info? If not, run make clean for pcl first (or remove the pcl build dir) and try again with VERBOSE=1 and -j1

demmeln gravatar image demmeln  ( 2014-02-11 01:19:22 -0500 )edit

Having the same problem here. Any luck with this?

TSC gravatar image TSC  ( 2014-02-11 06:38:47 -0500 )edit

Exactly! Thanks ahendrix!

TSC gravatar image TSC  ( 2014-02-11 07:00:57 -0500 )edit

@TSC, what about that full error log with VERBOSE=1 and -j1?

demmeln gravatar image demmeln  ( 2014-02-11 08:59:03 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-02-16 09:08:28 -0500

demmeln gravatar image

@TSC provided output with VERBOSE=1 and -j1 over at http://answers.ros.org/question/12684...

Might be it is the same issue of Eigen / PCL incompatibility here. I just answered there:

It seems like you have a Eigen version installed that is too new for PCL. It seems in 3.2 the sqrt function moved from eigen::internal::sqrt to eigen::sqrt. See this question:

http://answers.ros.org/question/12891...

So you could either try to change the source of PCL or make sure it is using eigen 3.1 to compile.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-31 12:57:32 -0500

Seen: 641 times

Last updated: Feb 16 '14