ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

How can I set a relative-path to compile my workspace in another machine ?

asked 2014-01-30 21:40:47 -0500

rosAS gravatar image

updated 2022-01-22 16:16:26 -0500

Evgeny gravatar image

Hello everyone,

I have written some code for publisher and subscriber and I am currently using SVN for versioning. I committed the entire workspace, now when I took the checkout on other machine, I am not able to compile the source code. I get the source-directory not found error.

I know that obviously its not the same workspace but is there a workaround to update the relative path, so that the next time anyone takes any checkout, the source code compiles on their machine ?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2014-01-31 05:49:21 -0500

ahendrix gravatar image

You should be a little more specific about what you commit to version control.

In general, you don't want to commit any anything that can be rebuilt by the build process.

Specifically for ROS, you don't want to commit:

  • The build, bin and lib directories in rosbuild packages
  • Generated message files, headers, etc
  • The build, devel and install directories in a catkin workspace
edit flag offensive delete link more

answered 2014-02-06 20:59:31 -0500

pmarinplaza gravatar image

Hello, I have gotten the same problem with git.

The steps I recommend you is make a svn ignore global list (in git is .gitignore) and put the name of the autogenerated files in order to not commit them into your rep. In rosbuild are:

edit flag offensive delete link more


delete CMakeCache.txt, CMakeFiles folder. Everything should compile....

McMurdo gravatar image McMurdo  ( 2014-07-07 13:39:44 -0500 )edit

Question Tools

1 follower


Asked: 2014-01-30 21:40:47 -0500

Seen: 780 times

Last updated: Feb 06 '14