ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ROS electric installation problem

asked 2011-12-22 10:24:03 -0500

Rasoul gravatar image

updated 2012-01-20 00:03:48 -0500

joq gravatar image

I want to install ros-electric-desktop, but I get the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-electric-desktop : Depends: ros-electric-eigen (= 1.6.0-s1323568233~natty) but it is not going to be installed
                        Depends: ros-electric-geometry-tutorials (= 0.1.3-s1323588691~natty) but it is not going to be installed
                        Depends: ros-electric-orocos-kinematics-dynamics (= 0.2.3-s1323568273~natty) but it is not going to be installed
                        Depends: ros-electric-visualization (= 1.6.7-s1323575414~natty) but it is not going to be installed
                        Depends: ros-electric-geometry-experimental (= 0.2.2-s1323584064~natty) but it is not going to be installed
                        Depends: ros-electric-geometry-visualization (= 0.1.1-s1323607694~natty) but it is not going to be installed
                        Depends: ros-electric-common-tutorials (= 0.1.2-s1323607993~natty) but it is not going to be installed
                        Depends: ros-electric-robot-model (= 1.6.3-s1323571492~natty) but it is not going to be installed
                        Depends: ros-electric-visualization-tutorials (= 0.2.3-s1323609388~natty) but it is not going to be installed
                        Depends: ros-electric-geometry (= 1.6.1-s1323568421~natty) but it is not going to be installed
                        Depends: ros-electric-laser-pipeline (= 1.2.0-s1323573853~natty) but it is not going to be installed
E: Broken packages

Any idea how to fix it?

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted

answered 2011-12-22 12:17:08 -0500

mjcarroll gravatar image

updated 2011-12-22 12:23:18 -0500

This is an apt problem, you should be able to clean up by doing the following:

First try:

sudo apt-get autoremove

Which prunes any dependencies that were installed automatically, but might not be correct. If that doesn't work, move on to:

sudo apt-get -f install

Which will finish any broken or cut-off installs and fix unmet dependencies. If that doesn't work, try

sudo apt-get clean all

Which cleans up apt's working directories.

Those will generally fix all apt problems that you may have, remember to always sudo apt-get update before beginning to install anything.

Edit: Possible Duplicates

edit flag offensive delete link more


Hi, thanks for the answer. I managed to solve the problem.
Rasoul gravatar image Rasoul  ( 2011-12-23 04:39:16 -0500 )edit

answered 2011-12-22 11:51:24 -0500

Ryan gravatar image

I've fought with this a few times recently, too. I've done the following in no particular order on a few machines and distributions, for both electric & diamondback:

  • Completed forgotten half-finished distro upgrades
  • Reviewing what's in /etc/apt/sources.list.d/ros-latest.list
  • Using aptitude install instead of apt-get install (you'll need to install aptitude first)
  • Uninstalling and re-installing with apt-get
  • Remembering to run apt-get update first

On my end, these errors seem to be correlated with upgrading a distro, then upgrading ROS.

edit flag offensive delete link more

answered 2012-01-18 03:28:13 -0500

Mike Gao gravatar image

updated 2012-01-18 03:30:24 -0500

Hi! I came across the same problem with you, my operation system is Oneiric. I think you should try sudo atitude install instead of sudo apt-get install, as Ryan said. The aptitude command worked quite well for me. Hope this could be helpful for you and others who are with the same problem.

edit flag offensive delete link more

answered 2012-11-08 04:08:49 -0500

andreas gravatar image

Just had to struggle with the same problem and found a solution:

sudo apt-get install libeigen3-dev=3.0.1-1+ros4~lucid


sudo apt-get install ros-electric-desktop-full
edit flag offensive delete link more

answered 2011-12-22 11:28:59 -0500

spiked3 gravatar image

Reading here;

looks like it is not yet supported, and the documentation does not reflect that, nor give any method to install an alternative other than do it yourself by hand.

joy, this is what I love about open source.

edit flag offensive delete link more


Oneric packages have been released for electric, it was announced on the ros-users mailing list on November 3:
mjcarroll gravatar image mjcarroll  ( 2011-12-22 12:13:04 -0500 )edit
I continue to run into problems trying to install ROS. Over three weeks now, still no runable system. Either ROS's use of apt is terribly broken or the apt system itself is. Anyone questioning this should try a clean install of the current ubuntu system and ROS nxt. see how long it takes to fail.
spiked3 gravatar image spiked3  ( 2012-01-18 07:16:09 -0500 )edit

Question Tools


Asked: 2011-12-22 10:24:03 -0500

Seen: 1,196 times

Last updated: Nov 08 '12