Ask Your Question
0

irobot_create_2_1 does not run

asked 2011-12-16 08:29:34 -0500

searchrescue gravatar image

updated 2011-12-26 13:13:51 -0500

tfoote gravatar image

Hi all, I am trying to run irobot_create_2_1 driver , i do rosmake successfully however i cannot run it. this is the error i am getting

rosrun irobot_create_2_1 driver.py Traceback (most recent call last): File "/opt/ros/electric/stacks/brown_drivers/irobot_create_2_1/bin/driver.py", line 15, in <module> from irobot_create_2_1.msg import SensorPacket ImportError: No module named irobot_create_2_1.msg

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-12-25 14:58:37 -0500

tjay gravatar image

Other threads have brought to my attention that I accidentally pulled both the Makefile and rosdep.yaml from the irobot_create_2_1 repo when doing some other maintenance work.I believe this is your problem (and why the older package release solved it for winterhater). This has been corrected both in the repo and in our newer package releases (though these of course take time to catch up). In the meantime, you can pull a fresh copy from the repo:

svn co https://brown-ros-pkg.googlecode.com/svn/trunk/experimental/irobot_create_2_1 irobot_create_2_1

or you can download the individually missing files: Makefile and rosdep.yaml .

My sincere apologies. This was really bone-headed and I will spend the requisite time on the wheel.

_Trevor

edit flag offensive delete link more
0

answered 2011-12-16 10:43:17 -0500

searchrescue gravatar image

I have found the problem. It is because the first time i downloaded the brown drivers for irobot i did not have all the dependencies . But i run this command again


sudo aptitude install ros-diamondback-brown-drivers


it completed its dependencies . I do not know why at first time it did not get all the files while installing. But while it did not work , rosmake was successful but there was no makefile in the package. Now there is as supposed to be. Now it works.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-16 08:29:34 -0500

Seen: 367 times

Last updated: Dec 25 '11