ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

roscd in hydro

asked 2014-01-28 12:24:34 -0500

prince gravatar image

updated 2014-01-28 17:03:57 -0500

ngrennan gravatar image


I have installed Hydro on Ubuntu 12.04 . I have also installed rosbash. I still do not have command roscd is not PATH env variable. Other ROS related environment variables are correctly set.

Do anyother person facing similar problem?

rgds Nitin

edit retag flag offensive close merge delete



Have you execute 'source /opt/ros/hydro/setup.bash' ?

gustavo.velascoh gravatar image gustavo.velascoh  ( 2014-01-28 18:01:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-01-28 18:11:24 -0500

ahendrix gravatar image

Because roscd has to change the working directory of the shell, it is implemented as a bash function and not as a script. This means that you will not find it on your path.

You can add roscd to your shell environment by installing rosbash and then sourcing the setup.bash for your distribution (/opt/ros/hydro/setup.bash for Hydro).

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-01-28 12:24:34 -0500

Seen: 248 times

Last updated: Jan 28 '14