Ask Your Question
3

Omni-directional navigation

asked 2011-12-15 17:59:57 -0500

Frederik gravatar image

updated 2012-03-29 14:16:27 -0500

Kevin gravatar image

Hi all, i am currently working with an omni-directional platform and try to get the navigation stack running. This already working but only in a differential drive manner. Is there any stack/repository which already implemented a omni-directional path planner/execution? I looked into the tum package, since rosie seems to move in some videos omni-directional.

Regards, Frederik

edit retag flag offensive close merge delete

Comments

Just to make sure: Is your local_base_planner (http://www.ros.org/wiki/base_local_planner ) configured with holonomic_robot set to true? Acording to the docs, thats what makes the planner issue strafing commands to the base. Otherwise it uses differential mode. Best regards, Ben
Ben_S gravatar imageBen_S ( 2011-12-15 20:23:37 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2011-12-16 01:13:22 -0500

DimitriProsser gravatar image

As @Ben_s mentioned, the navigation stack supports holonomic (omni-direction) path planning. The pr2 has this ability. If you set the holonomic_robot parameter to true, move_base will generate plans that contain both x and y motion, and it will output a cmd_vel message with an x, y, and theta component, rather than just an x and theta. It's up to you to interpret this message appropriately for the drive train of your robot.

edit flag offensive delete link more
-1

answered 2012-03-10 03:50:51 -0500

tomas gravatar image

Hi,

I am trying to setup the omni navigation for my robot. So far I was completely unsuccessful. I have set the holonomic_robot variable to true and I am not getting any y commands at all. I checked the ROS source files for the meaning of the y_vels and it looks like it is a list of permitted y (strafing) velocities. I tried to set up a fine range for it (e.g. -1.0, -0.9, ..., 1.0 (max_vel_x = 1.0)) but still nothing. I checked the parameters on the parameter server using 'rosparam get' and I got:

holonomic_robot = true

y_vels = "default_value (-0.3, -0.1 0.1 -0.3)" - my yaml file has no effect at this at all.

Any suggestions would be greatly appreciated. Thank you

edit flag offensive delete link more

Comments

I have gone through a similar exercise with my robot I noticed if the target is say 45 deg to the right it will turn and drive rather than strafe the whole way. The Y vel is mostly used for final position. If you publish X 1 and y1 on cmd_vel dose it travel at 45 degrees?

Peter Heim gravatar imagePeter Heim ( 2012-03-10 10:00:44 -0500 )edit

Yes it does. So far I was using fake odometry (just transforming and integrating the velocity commands) for the simaulations in rviz. I will try to travel to "closer" goals but I would like to travel longer distances sideways. I checked the rxplot for the Y command and it is just a flat line.

tomas gravatar imagetomas ( 2012-03-22 06:06:48 -0500 )edit

You have to change the value of 'y_vels' atribute in the .yaml file. i.e. y_vels: '-0.6, -0.1, 0.1, 0.6' After that, you should see the new value with the command, 'rosparam get foo/y_vels' I hope it helps you.

Jose Luis gravatar imageJose Luis ( 2013-12-03 21:16:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-15 17:59:57 -0500

Seen: 2,010 times

Last updated: Mar 10 '12