Ask Your Question

ar_pose artoolkit problem

asked 2011-12-06 21:27:50 -0500

Maurizio88 gravatar image

hi all, i'm working with ar_pose package. When i try to run demo:

roslaunch ar_pose demo_single.launch

the demo doesn't run correctly and see this message from terminal.

[ERROR] [1323256898.236396302]: Client [/ar_pose] wants topic /usb_cam/camera_info to have datatype/md5sum [sensor_msgs/CameraInfo/c9a58c1b0b154e0e6da7578cb991d214], but our version has [sensor_msgs/CameraInfo/1b5cf7f984c229b6141ceb3a955aa18f]. Dropping connection. [ERROR] [1323256908.957549386, 1275671534.365555223]: Client [/rviz] wants topic /usb_cam/camera_info to have datatype/md5sum [sensor_msgs/CameraInfo/c9a58c1b0b154e0e6da7578cb991d214], but our version has [sensor_msgs/CameraInfo/1b5cf7f984c229b6141ceb3a955aa18f]. Dropping connection.Dropping connection.

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted

answered 2011-12-08 18:33:40 -0500

Procópio gravatar image

You can solve this issue running the rosbag fix command on your downloaded bag files. The program will work, but still there is going to be some issues with the markers drawing. This issue and its fix is explained here. But have in mind that this fix is only for the demos. If you run the node with your camera, things should be ok. regards.

edit flag offensive delete link more

answered 2012-05-14 12:25:03 -0500

Janina gravatar image

I have the same error message. What do you do to solve the problem?

edit flag offensive delete link more


check the answer marked as correct.

Procópio gravatar image Procópio  ( 2012-05-15 01:42:52 -0500 )edit

answered 2011-12-08 19:25:22 -0500

Maurizio88 gravatar image

i solved my problem from here.

It's better or worse?

edit flag offensive delete link more

answered 2011-12-07 01:08:41 -0500

DimitriProsser gravatar image

ar_pose is looking at a version of the message with different fields than it expects. If the message description of sensor_msgs::CameraInfo is different between the topic and the subscriber, you will see this error. Since Rviz is having the same problem, I would guess that whatever node is publishing /usb_cam/camera_info is publishing incorrectly or is from an older version of ROS than you're using.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2011-12-06 21:27:50 -0500

Seen: 1,016 times

Last updated: May 14 '12