Ask Your Question
3

uvc_camera

asked 2011-11-30 08:49:52 -0600

JohnC gravatar image

updated 2011-12-07 01:54:35 -0600

I was happily using uvc_camera in my development. Everything was working ok. Then I performed a linux upgrade that said one package was being removed and now I don't have uvc_camera. I don't seem to be able to down load it from camera_umd. Is there a replacement? I have tried upgrading to electric but that doesn't have uvc_camera. Also I now cannot rosmake my code. the package seems to have cturtle hard coded. is there a upgrade process for taking packages built on one version to work on a later version.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-11-30 14:56:19 -0600

Ken gravatar image

Are you using ROS's unstable distribution on Ubuntu 11.10? If so, the immediate problem is that the image_common stack isn't yet building for that combination of ROS and Ubuntu.

You might have better luck with another UVC driver if you find one that doesn't use image_transport (for JPEG/Theora streams) or camera_info_manager (for CameraInfo), but anything that uses those or other components of image_common will be missing from the deb repository.

Alternatively, you could try building image_common and camera_umd from source, or you could switch to electric.

edit flag offensive delete link more

Comments

Thanks for your answer. I was using unstable on ubuntu 11.04.
JohnC gravatar image JohnC  ( 2011-12-01 12:10:55 -0600 )edit
sorry, I tried to upgrade to electric but did not find uvc_camera.
JohnC gravatar image JohnC  ( 2011-12-01 12:15:12 -0600 )edit
sorry, I tried to upgrade to electric but did not find uvc_camera.
JohnC gravatar image JohnC  ( 2011-12-01 12:15:14 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-30 08:49:52 -0600

Seen: 446 times

Last updated: Dec 07 '11