Ask Your Question
0

Turtlebot calibration returns absolute parameters not multipliers?

asked 2011-11-28 05:50:42 -0600

130s gravatar image

updated 2011-11-29 05:36:43 -0600

Tutorial says that the result of calibration by "roslaunch turtlebot_calibration calibrate.launch" are to be used to multiply the current parameters. But I've been experiencing with my 4 turtlebots that multiplication makes things worse. Instead, replacing with those returned values tends to show better result. Has there been change here or am I doing something wrong? Thank you.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-28 07:34:18 -0600

tfoote gravatar image

Make sure that you restart your turtlebot_node between runs or use dynamic reconfigure's reconfigure_gui to change the values of the parameters in the node before running. Otherwise they will not be reread by the driver. The default values are close to 1, so if the corrections are close to absolute when using the default parameters.

edit flag offensive delete link more

Comments

Using dynamic reconfigure, multiplying the current values by the result values improves calibration. I also updated wiki page to clarify that rebooting node is needed. Thanks!
130s gravatar image130s ( 2011-11-29 05:21:27 -0600 )edit
After changing the params (with dynamic reconfigure or "rosparam set" command-line tool), you can "rosnode kill turtlebot_node" and it will respawn automatically with the new params. This way, no reboot is needed.
Nick Armstrong-Crews gravatar imageNick Armstrong-Crews ( 2011-12-27 14:43:11 -0600 )edit
0

answered 2012-01-15 09:52:51 -0600

This didn't help me much, as I seem to have an actual problem with the calibration routine. Consecutive runs, updating the values as instructed each time, resulted in continually lower gyro scale corrections. I think it would have gone to zero eventually. Finally, I just eyeballed it in the gmapping demo. I could see how far off it was when I turned. I finally came to a value of 2.4 for the gyro scale correction. With that value, in the mapping demo, when I turned, the mapped walls followed the laser points exactly, requiring much less pose re-estimation. Mapping went like a snap.

edit flag offensive delete link more

Comments

2.4 gyro scale correction worked for me as well. The calibration launch file was returning something like 1.3 and the map was way out of shape :) . When we used 2.4 the map was far more better.

rohan gravatar imagerohan ( 2012-05-31 04:11:38 -0600 )edit

Do you have a 150, 250 or 300 gyro?

NeuralJuiceBox gravatar imageNeuralJuiceBox ( 2013-02-11 04:48:30 -0600 )edit

I think so we had a 150 gyro!!

rohan gravatar imagerohan ( 2013-02-25 04:50:44 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-28 05:50:42 -0600

Seen: 1,891 times

Last updated: Jan 15 '12