Ask Your Question
0

getting permissions

asked 2011-11-22 13:00:07 -0600

MovieMaker gravatar image

updated 2014-01-28 17:10:50 -0600

ngrennan gravatar image

I installed ROS on both the Robot (netbook) and the desktop computers after installing UBUNTU.

I am running a roomba, but not a 5XX or a create. I just need to CHANGE the port settings.

I tried to change a file by gedit turtlebot_node.py which was supposed to have the tty,usb0 inside. Once I changed it, it would not let me save it because I did not have permissions.

I have read the manuals and tried every which way to change it. Once I can see the port on the roomba and the kinect, then I can start doing the turtlebot, etc.

Any ideas welcome.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-23 11:14:19 -0600

tfoote gravatar image

updated 2011-11-23 11:15:26 -0600

There is a parameter to set the port for the node. This is a much better solution than editing the code installed on your system. The parameter is ~port. See the turtlebot_node wiki page

edit flag offensive delete link more
0

answered 2011-11-23 00:41:57 -0600

DimitriProsser gravatar image

If all you have to do is edit the turtlebot_node.py file, could you just access it as an administrator with the sudo command?

sudo gedit turtlebot_node.py
edit flag offensive delete link more

Comments

This is the fix for your stated question. However it is not recommended to modify things installed onto your system. Instead you should consider using a source checkout.
tfoote gravatar imagetfoote ( 2011-11-23 11:12:34 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-22 13:00:07 -0600

Seen: 168 times

Last updated: Nov 23 '11