Ask Your Question
0

Service call failed while launching the gazebo [closed]

asked 2011-11-19 22:28:25 -0500

Ganta Kranthi gravatar image

updated 2011-11-21 19:45:48 -0500

Dear friends

I tried launching gazebo with the following commands:

  1. roscore
  2. $ roslaunch youbot_description youbot_arm_description.launch
  3. $ roslaunch youbot_description youbot_arm_publisher.launch

...... so first 2 are working fine and when I try to do 3rd one to launch gazebo it says gazebo successfully initialized and model was shown for 2 secs and after that it says process has died as described below..... so please if anyone can help it would be of great help ..... please try to help us.

Gazebo successfully initialized
/home/youbot/ros_stacks/simulator_gazebo/gazebo/build/gazebo/server/controllers/ControllerFactory.cc:99 : Exception: Failed to load libgazebo_ros_controller_manager.so: libgazebo_ros_controller_manager.so: cannot open shared object file: No such file or directory
Main simulation loop failed
/home/youbot/ros_stacks/simulator_gazebo/gazebo/build/gazebo/server/controllers/ControllerFactory.cc:99 : Exception: Failed to load libgazebo_ros_controller_manager.so: libgazebo_ros_controller_manager.so: cannot open shared object file: No such file or directory
Service call failed: transport error completing service call: unable to receive data from sender, check sender's logs for details
spawning success None
[gazebo-2] process has died [pid 2498, exit code -11].
log files: /home/youbot/.ros/log/e142418c-136d-11e1-ad57-002682c60600/gazebo-2*.log
[youbot_gazebo_model-3] process has finished cleanly.
log file: /home/youbot/.ros/log/e142418c-136d-11e1-ad57-002682c60600/youbot_gazebo_model-3*.log
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by kwc
close date 2012-02-29 07:42:16

Comments

Please update your original question and mark the answer to your question when available instead of posting new questions as "answers". This is not an e-mail thread, it's a Q&A/Stackoverflow forum.

kwc gravatar image kwc  ( 2012-02-29 07:42:10 -0500 )edit

6 Answers

Sort by » oldest newest most voted
1

answered 2011-11-21 19:53:08 -0500

Your log says that Gazebo couldn't find the file libgazebo_ros_controller_manager.so. It's in the package pr2_gazebo_plugins (in the stack pr2_simulator), so make sure that pr2_simulator is installed and run a rosmake pr2_gazebo_plugins.

edit flag offensive delete link more
0

answered 2011-11-22 20:10:13 -0500

Ganta Kranthi gravatar image

Dear Samsoem

Thank you very much for responding and i tried yours and this is what I had found and faced ..... please check this and respond to the result what we got ..... hope it will be understandable to you.

for this i tried running the third one second and second one third and the gazebo launches successfully without the robot object in it..... but before it says "Gazebo launches successfully" it gives few red lines, mentioned below:

Part of the Player/Stage Project [http://playerstage.sourceforge.net]. Copyright (C) 2003 Nate Koenig, Andrew Howard, and contributors. Released under the GNU General Public License.

loading model xml from ros parameter Traceback (most recent call last): File "/home/youbot/ros_stacks/simulator_gazebo/gazebo/scripts/spawn_model", line 227, in <module> sm.callSpawnService() File "/home/youbot/ros_stacks/simulator_gazebo/gazebo/scripts/spawn_model", line 183, in callSpawnService model_xml = rospy.get_param(self.param_name) File "/home/youbot/ros_stacks/ros_comm/clients/rospy/src/rospy/client.py", line 377, in get_param return _param_server[param_name] #MasterProxy does all the magic for us File "/home/youbot/ros_stacks/ros_comm/clients/rospy/src/rospy/msproxy.py", line 117, in __getitem__ raise KeyError(key) KeyError: 'robot_description' do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly. Try adjusting the vblank_mode configuration parameter. [robot_state_publisher-4] process has died [pid 2659, exit code 255]. log files: /home/youbot/.ros/log/8d993482-15a7-11e1-9a5d-002682c60600/robot_state_publisher-4.log [youbot_gazebo_model-3] process has died [pid 2658, exit code 1]. log files: /home/youbot/.ros/log/8d993482-15a7-11e1-9a5d-002682c60600/youbot_gazebo_model-3.log directory [/tmp/gazebo-youbot-0] already exists (previous crash?) the owner gazebo server (pid=2089) is not running. deleting the old information of the directory [/tmp/gazebo-youbot-0] Param [quickStep] is deprecated: [replace quickStep with stepType] Param [quickStepIters] is deprecated: [replace quickStepIters with stepIters] Param [quickStepW] is deprecated: [replace quickStepW with stepW] Gazebo successfully initialized

edit flag offensive delete link more
0

answered 2011-11-22 19:11:10 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Yes, I am on Oneiric. So I tried to compile pr2-simulator from sources. Unfortunately,

pr2_simulator/pr2_gazebo_plugins/src/gazebo_ros_controller_manager.h

has several includes that could not be found.

#include "gazebo.h"
#include "physics/World.hh"
#include "physics/Model.hh"
#include "physics/physics.h"
#include "common/Time.hh"

I was able to locate the first three and the last header, and changing to

#include "gazebo/gazebo.h"
#include "gazebo/World.hh"
#include "gazebo/Model.hh"
#include "gazebo/Time.hh"

solved the issue. But I don't have physics.h in my filesystem at all. Any ideas to where it belongs?

edit flag offensive delete link more
0

answered 2011-11-21 23:08:36 -0500

sergey_alexandrov gravatar image

updated 2011-11-21 23:09:08 -0500

I get a similar error with libgazebo_ros_controller_manager.so, however that does not make my simulation to fail, i.e. the Gazebo window and a robot are displayed:

Error: [/tmp/buildd/ros-electric-simulator-gazebo-1.4.9/debian/ros-electric-simulator-gazebo/opt/ros/electric/stacks/simulator_gazebo/gazebo/build/gazebo/server/controllers/ControllerFactory.cc:101]
Failed to load libgazebo_ros_controller_manager.so: libgazebo_ros_controller_manager.so: cannot open shared object file: No such file or directory
[/tmp/buildd/ros-electric-simulator-gazebo-1.4.9/debian/ros-electric-simulator-gazebo/opt/ros/electric/stacks/simulator_gazebo/gazebo/build/gazebo/server/controllers/ControllerFactory.cc:71]
  Error Loading Controller of type [gazebo_ros_controller_manager], skipping

I tried to install pr2_simulator stack with apt-get, however it does not seem to exist (Ubuntu Oneiric):

$ sudo apt-get install ros-electric-pr2-simulator
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-electric-pr2-simulator
edit flag offensive delete link more

Comments

Are you on oneiric? pr2-simulator has not been packaged for oneiric yet: https://code.ros.org/trac/wg-ros-pkg/ticket/5163
Martin Günther gravatar image Martin Günther  ( 2011-11-22 06:50:57 -0500 )edit
0

answered 2011-11-22 20:13:47 -0500

Ganta Kranthi gravatar image

Dear Martin

Thank you too for responding to our question and we tried what you suggested us and this is what we are facing now ..... Please check through this and help us for proceeding further ..... hope it will be understandable to you .....

Where exactly can I find this library seperately, I did try downloading the entire pr2_simulator and yet inside the pr2_gazebo_plugins I was not able to find this library..... so where can I get exactly and look also what we had got which is mentioned below ..... Please help us.....

regarding this, i have installed the pr2_gazebo_plugins, and when i try to run the command "$ make", i get this error:

Linking CXX shared library ../lib/libgazebo_ros_controller_manager.so /usr/bin/ld: cannot find -lpr2_controller_manager collect2: ld returned 1 exit status make[3]: * [../lib/libgazebo_ros_controller_manager.so] Error 1 make[3]: Leaving directory /home/youbot/ros_stacks/pr2_gazebo_plugins/build' make[2]: *** [CMakeFiles/gazebo_ros_controller_manager.dir/all] Error 2 make[2]: Leaving directory/home/youbot/ros_stacks/pr2_gazebo_plugins/build' make[1]: [all] Error 2 make[1]: Leaving directory `/home/youbot/ros_stacks/pr2_gazebo_plugins/build' make: ** [all] Error 2

and when i run the command "$rosmake", it get one failure.....

rosmake ] Output from build of package pr2_controller_manager written to: [ rosmake ] /home/youbot/.ros/rosmake/rosmake_output-20111123-085708/pr2_controller_manager/build_output.log [rosmake-1] Finished <<< pr2_controller_manager [FAIL] [ 16.72 seconds ]
[ rosmake ] Halting due to failure in package pr2_controller_manager. [ rosmake ] Waiting for other threads to complete. [ rosmake ] Results:
[ rosmake ] Built 73 packages with 1 failures.
[ rosmake ] Summary output to directory
[ rosmake ] /home/youbot/.ros/rosmake/rosmake_output-20111123-085708

edit flag offensive delete link more

Comments

you also need all dependencies of pr2_simulator, in this case pr2_mechanism. It's best to install the Debian packages rather than compiling everything from source.
Martin Günther gravatar image Martin Günther  ( 2011-11-23 19:10:03 -0500 )edit
thank you, pr2_mechanism is also been installed and both make and rosmake works fine but we get the above shown error ..... and wt about debian packages ..... wr can we get those and how they r to be used .... please help us as this is the last stage for us .....
Ganta Kranthi gravatar image Ganta Kranthi  ( 2011-11-24 00:46:01 -0500 )edit
0

answered 2011-11-20 02:45:36 -0500

samsoem gravatar image

Is this caused by opening the same world model twice (i.e. an empty world) in multiple launch files?

edit flag offensive delete link more

Comments

Thanks for your reply. But its not happened by opening the same model twice. It is happening when we type the 3rd command which is a publisher one as I mentioned before.
Ganta Kranthi gravatar image Ganta Kranthi  ( 2011-11-20 05:09:36 -0500 )edit
what if you do the third one second? try renaming any same named nodes? I sometimes escaped this problem by very quickly launching two things after another.. before I found out what the real problem was, you can debug your lauch files by commenting out the code and then uncommenting it one by one
samsoem gravatar image samsoem  ( 2011-11-20 21:43:22 -0500 )edit

Question Tools

Stats

Asked: 2011-11-19 22:28:25 -0500

Seen: 4,222 times

Last updated: Nov 22 '11