Ask Your Question
1

non-existent package 'ros_comm' [closed]

asked 2014-01-20 21:06:27 -0500

courrier gravatar image

updated 2014-01-21 01:21:19 -0500

Hi all,

I've installed ROS Groovy via the Ubuntu repository (12.04) and now I try to run the pr2_object_manipulation example but get an issue during compiling with rosmake, it stops on error "'ecto_ros' depends on non-existent package 'ros_comm'".

However ros_comm seems to be a core component of ROS and it seems to be actually installed. See the commands I ran below trying to understand what's going on.

rosetta@dell:~/catkin_ws$ rosmake pr2_object_manipulation
[...] Plenty of packages successfully compiled [...]
{-------------------------------------------------------------------------------
  mkdir -p bin
  cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=/opt/ros/groovy/share/ros/core/rosbuild/rostoolchain.cmake  ..
  -- Action Files:UserCommand.action
  -- Generating Messages for ActionUserCommand.action
  -- Using CATKIN_DEVEL_PREFIX: /home/rosetta/catkin_ws/src/pr2_object_manipulation/applications/pr2_interactive_object_detection/build/devel
  -- Using CMAKE_PREFIX_PATH: /opt/ros/groovy
  -- This workspace overlays: /opt/ros/groovy
  -- Using Debian Python package layout
  -- Using CATKIN_ENABLE_TESTING: ON
  -- Call enable_testing()
  -- Using CATKIN_TEST_RESULTS_DIR: /home/rosetta/catkin_ws/src/pr2_object_manipulation/applications/pr2_interactive_object_detection/build/test_results
  -- Found gtest sources under '/usr/src/gtest': gtests will be built
  -- catkin 0.5.77
  -- /home/rosetta/catkin_ws/src/pr2_object_manipulation/applications/pr2_interactive_object_detection/msg/UserCommandAction.msg
  [rosbuild] Building package pr2_interactive_object_detection
  Failed to invoke /opt/ros/groovy/bin/rospack deps-manifests pr2_interactive_object_detection
  [rospack] Error: package/stack 'ecto_ros' depends on non-existent package 'ros_comm' and rosdep claims that it is not a system dependency. Check the ROS_PACKAGE_PATH or try calling 'rosdep update'


  CMake Error at /opt/ros/groovy/share/ros/core/rosbuild/public.cmake:129 (message):


    Failed to invoke rospack to get compile flags for package
    'pr2_interactive_object_detection'.  Look above for errors from rospack
    itself.  Aborting.  Please fix the broken dependency!

  Call Stack (most recent call first):
    /opt/ros/groovy/share/ros/core/rosbuild/public.cmake:203 (rosbuild_invoke_rospack)
    CMakeLists.txt:20 (rosbuild_init)


  -- Configuring incomplete, errors occurred!
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package pr2_interactive_object_detection written to:
[...]


rosetta@dell:~/catkin_ws$ rospack find ros_comm
[rospack] Error: stack/package ros_comm not found

rosetta@dell:~/catkin_ws$ roscd ros_comm
rosetta@dell:/opt/ros/groovy/share/ros_comm$                # cd is successful, ros_comm exists!

rosetta@dell:/opt/ros/groovy/share/ros_comm$ echo $ROS_PACKAGE_PATH
/opt/ros/groovy/share:/opt/ros/groovy/stacks:/home/rosetta/catkin_ws/src/pr2_object_manipulation:/opt/ros/groovy/share

rosetta@dell:~/opt/ros/groovy/share/ros_comm$ rosdep install ros_comm
#All required rosdeps installed successfully                # I could not install it again since it's already installed

So what's going on?

Thank you for your help.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-08-14 01:55:52.576882

Comments

Did you try rospack profile?

BennyRe gravatar imageBennyRe ( 2014-01-21 04:42:20 -0500 )edit

Have You tried `rosdep update`, as suggested in error message? :)

Kamiccolo gravatar imageKamiccolo ( 2014-01-21 06:54:57 -0500 )edit

Yes I did try. Without any change unfortunately :( Also, I compiled and installed ecto_ros from sources with success. But I don't know how to prevent rosmake continuing compiling ecto_ros, because I still have the same error when I compile the pr2_etc package

courrier gravatar imagecourrier ( 2014-01-21 07:39:20 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-01-21 05:28:56 -0500

courrier gravatar image

What should I see with it? If ros_comm is a zombie or so?

rosetta@dell:~/catkin_ws$ rospack profile
Full tree crawl took 0.072905 seconds.
Directories marked with (*) contain no manifest.  You may
want to delete these directories.
To get just of list of directories without manifests,
re-run the profile with --zombie-only
-------------------------------------------------------------
0.045998   /opt/ros/groovy/share
0.020576   /opt/ros/groovy/stacks
0.009296 * /opt/ros/groovy/share/common-lisp
0.009165 * /opt/ros/groovy/share/common-lisp/ros
0.007766   /opt/ros/groovy/stacks/orocos_toolchain
0.007130 * /opt/ros/groovy/stacks/orocos_toolchain/install
0.005239 * /opt/ros/groovy/stacks/orocos_toolchain/install/include
0.004546   /home/rosetta/catkin_ws/src
0.003393   /home/rosetta/catkin_ws/src/pr2_object_manipulation
0.003285 * /opt/ros/groovy/stacks/orocos_toolchain/install/include/rtt
0.002890 * /opt/ros/groovy/share/doc
0.002791 * /opt/ros/groovy/share/doc/pcl-1.6
0.002744 * /opt/ros/groovy/share/doc/pcl-1.6/tutorials
0.002533 * /opt/ros/groovy/share/doc/pcl-1.6/tutorials/sources
0.001336   /home/rosetta/catkin_ws/src/pr2_object_manipulation/manipulation
0.001025 * /opt/ros/groovy/share/common-lisp/ros/moveit_msgs
0.001002 * /opt/ros/groovy/stacks/orocos_toolchain/install/lib
0.000969 * /opt/ros/groovy/stacks/orocos_toolchain/install/include/utilmm
0.000937   /home/rosetta/catkin_ws/src/pr2_object_manipulation/applications
0.000822   /opt/ros/groovy/stacks/arm_navigation

Apprently nothing related to ros_comm or ecto_ros.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-01-20 21:06:27 -0500

Seen: 359 times

Last updated: Jan 21 '14