Ask Your Question
0

Starting the Manipulation Pipeline: self_filter.yaml

asked 2011-11-16 02:48:34 -0500

Dr Z gravatar image

ROS Electric
Ubuntu Natty Narwhal


Hello everybody,

I'm following the tutorial Starting the Manipulation Pipeline". When I run roslaunch pr2_tabletop_manipulation_launch pr2_tabletop_manipulation.launch I have the following error message:

error loading <rosparam> tag:<br> file does not exist [/opt/ros/electric/stacks/pr2_arm_navigation/pr2_arm_navigation_perception/config/self_filter.yaml]<br> XML is <rosparam command="load" file="$(find pr2_arm_navigation_perception)/config/self_filter.yaml"/>

Indeed self_filter.yaml does not exist in the directory.

Could someone please point me in the right direction here?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-16 08:13:30 -0500

VN gravatar image

Change the file name to one of these (as per your requirement): old_self_filter.yaml ; self_filter_left.yaml ; self_filter_right.yaml. Because of frequent updates file name have been changed and tutorials that you are following may be old. If you don't have any of these files then get a fresh copy of pr2_arm_navigation.

edit flag offensive delete link more

Comments

Thanks, I'll try that.
Dr Z gravatar image Dr Z  ( 2011-11-19 04:21:32 -0500 )edit
Thanks VN, renaming one of these files worked for me.
Dr Z gravatar image Dr Z  ( 2011-11-21 07:34:41 -0500 )edit
1

answered 2011-11-16 08:16:40 -0500

jbarry gravatar image

updated 2011-11-16 08:33:14 -0500

I saw this problem this afternoon too. However, I just apt-updated ROS and it is fixed now. You need to update pr2_object_manipulation_launch, note, not pr2_arm_navigation. The laser+stereo-perception.launch file was calling self_filter.yaml which no longer exists. In the newer version, it correctly calls self_filter_left/right.yaml.

edit flag offensive delete link more

Comments

Thank you for your answer. I couldn't find pr2_object_manipulation_launch in the Electric repository. I followed VN comments and it worked for me.
Dr Z gravatar image Dr Z  ( 2011-11-20 12:00:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-16 02:48:34 -0500

Seen: 215 times

Last updated: Nov 16 '11